ONTAP Discussions

"Previous versions" , VSS & CIFS Shares


Hi all,


We have successfully configured a clustered Data Ontap 8.3.1 CIFS Share, joined it to our AD domain, and set up a snapshot policy for the corresponding volume.


From the client view, the "previous versions" is ... weird !


If you right-click on a file, and select "restore previous versions", you obtain : "No previous versions available".


But if you right-click on a directory, and select "restore previous versions", you can browse the different "previous versions" corresponding to the available snapshots on the NetApp side. And you can browse/restore/etc...


I tried many different files and folder, always the same result !


Any idea why Files & Directories have a diferent behavior ?





Re: "Previous versions" , VSS & CIFS Shares


try modifying an existing text file, save it, and check for previous versions again. As I understand, you have setup a new CIFS share and populated it with some files, right? If the files were *not modified* after a snapshot creation, no previous version will be listed for them whereas, for directories, for every snapshot which is created after the directory creation, there will be one previous version regardless that they have been modified or not.  That is by design.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums