ONTAP Discussions

unable to see snapshots in Windows Explorer - Previous Versions


Hi all,


We`ve migrated our CIFS Environment from 7-Mode to cDOT.

Now we have the Problem that Snapshots are not visible in Windows Explorer / Proberties / Previous Versions.

I can see all Snapshot when open Drive or UNC Path \~snapshot, but in Explorer i get the Message : there are no previous versions available.

Snapshot Directory is always set to visivle in Volume /Snapshot Configuration.

our System:

Ontap 9.1


Windows 7/10

Maybe someone has an Idea what cause this Issue.






Hi Mario,


Have you checked the storage configuration in comparison to the details of the following KB




Does the issue exist for all users and CIFS shares? Have you checked the CIFS Share ACL's and NTFS permissions?

If the CIFS share is created on a qtree or folder within the volume have you tried browing snapshots from the root of the volume?



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Hi Matt,


Thank you for replay.

I guess that Snapshot Proberites for Volumes and Share are correct .

Running a Console Command shows me for Shares: showsnapshot and for Volumes: Snapshot Dir Aceesss-enabled = true

All CIFS Volunes/Folders are transitioned from 7-Mode and just located directly on Volumes,so Permissions does not changed.

I am as a member of the Builtin\Administrators and Domain Admin should have all necessary rights, but still see Snapshots only when type a Path followedby  \~snapshot.

ex. \\VSM\volume\~snashot or \\VSM\share\~snapshot.






well, seems to be i`ve to upgrade my Ontap to 9.1P1


many Thanks for the Link -was very helpfull


We're running Ontap 9.1P1 and are experiencing the same issues.


CIFS volumes/shares in qtree's migrated from a 7-Mode HA Pair running 8.2.4P4 using the 7-MTT.


I can list the snapshots via cmd prompt, then type in .snapshot\snapshot_dir_name in Windows Explorer to list the snapshots in that directory.


The snapshot directory visible setting is enabled on each share, and snapdir-access is true at the volume.



I created a volume on a CIFS SVM, created a share on it, enabled show snapshot directory, and when I browse that share, I see the snapshot directory.  I snapped the volume, and renamed a test directory in the share, and still do not see anything on the previous versions tab, but the original directory name is visible in the ~snapshot\snapshot_datestamp_timestamp directory.


My end users rely on this functionality.  I checked the show symlinks options on the shares, and everything appears correct.

The test share I created now shows previous versions when the hourly.XX snapshots took place.


None of the migrated shares show them.

I started removing snapshots created on the 7-Mode system that were migrated with the volumes/qtrees/shares, and the ~snapshot directory is visible now with folder options tweaked to show all files.  Still not showing up in Previous Versions tab.


I tried restarting CIFS on that SVM, no change in the Previous Versions tab.




we've had the same problem after migrating from 7-Mode to cDOT using the 7-MTT.

Are the share-properties "showsnapshot" and "show-previous-versions" set on your shares?

It seems that these attributes are not migrated by the 7-MTT.


You can check this like this:

share properties show -vserver <vserver-name> -share-name <share-name>


If the options are not set, you can set them using the following commands:

share properties add -vserver <vserver-name> -share-name <share-name> -share-properties showsnapshot

share properties add -vserver <vserver-name> -share-name <share-name> -share-properties show-previous-versions


Afterwards the explorer.exe has to be restarted.

We had to add "showsnapshot" AND "show-previous-versions", one of them was not enough.


This was the solution in our case, hope that it'll help you too.


The show-previous-versions was the issue.  It doesn't transition with volumes migrated with the 7-MTT.


 Kosta93's solution worked for us follwing migration to ONTAP 9. You can run the command in one line, though I couldn't find a way to change multiplie shares with a one-liner. 


share properties add -vserver <vserver-name> -share-name <share-name> -share-properties showsnapshot, show-previous-versions


If you simply want to set it on all shares you can use * for the share name or a partial name with a * to act as a wildcard. Even though the filer will likely give some errors for the admin and ipc shares it works fine for the others



yourvservername::*> vserver cifs share properties add -vserver yourvservername -share-name * -share-properties show-previous-versions


Error: command failed on vserver "yourvservername" share-name "admin$": Failed to modify CIFS share "admin$". Reason: Cannot modify the share-properties of the standard share "admin$".

Warning: Do you want to continue running this command? {y|n}: y


Error: command failed on vserver "yourvservername" share-name "ipc$": Failed to modify CIFS share "ipc$". Reason: Cannot modify the share-properties of the standard share "ipc$".

Warning: Do you want to continue running this command? {y|n}: y


259 entries were acted on.