ONTAP Hardware

Not enough spare disks error


Hi Guys,

I've taken over the management of several NetApp filers, unfortunatly I don't have a huge amount of experence with NetApp so I'm on a ver steep learning curve.

I've picked up the following error:  "There are not enough spare disks. /aggr0/plex0/rg0: Please add spare disks supporting block checksums with minimum size: Used 2".

It looks to me like the filer has been setup with out any spare disks (0 failed/0 spare)

This is on a FAS2050.

When I have a look at the disks in Storage -> Disks -> Manage

I see I have a number of disks with the tyope of partner, a few as data, 1 as partner, 1 as dparity and one unowned.  What do all these types mean? (I've attached a screen shot)

Can anyone shed any light on this for me?



Mark -

Welcome to the NetApp community !

I'm sure there's folks here to shed light on your problems...

Do you have your NOW.netapp.com access ?


Have you found the documentation pages on filerview ?

( http://myfiler/na_admin )

You're correct that you're running with no spares on at least one filer,

but if you see 'partner' disks you've got a cluster. There's another head

for you to log onto and check out.

How many disks total do you have ?

How many aggregates ?

If you've got a dparity disks you could go down to RAID4, but I wouldn't want to.

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff
Senior Systems Architect / NetApp Certified Instructor

(P.S. I appreciate points for helpful or correct answers.)


Hi Eugene,

thanks for the welcome.

I don't think I have access to NOW, not sure though.  The systems I'm responsable for have been in situ for about 5 years, we have some doco but its mostly out of date.

I found the other head.

Head one has 19 Disks, 2 spare, 0 failed and two Aggregates (aggr0 = 5 disks and aggr1 = 12 disks)

Head two has 5 Disks, 0 spare, 0 failed and two Aggregates (aggr0 = 5 disks)


Please post “sysconfig -r” output from both controllers.


I've attached the sysconfig -r output as requested.  Note, this was generated after I ran the disk assign all command


Your aggregate is built with 15K RPM disks and spare is 10K RPM disk. By default NetApp won’t allow mixing different speed in the same aggregate due to possible performance impact. If you have no way to replace spare disk with 15K RPM one, you could change raid.rpm.fcal.enable to allow mix.

Please post command output inline in message text. I use e-mail to read and reply (and I expect I am not alone); having to click click click through all screens just to see attachment takes far more time than simply answering message.


Hi Mark, first of all welcome. Hope we can help.

From the screenshot which you have posted it, I can see that this is a FAS2050A system and so the disks marked as Partner in this case are not of concern. they have been assigned to the other controller.

If it was me the first thing I'll be doing is trying to bring disk 0c.00.06 into Aggr0. As it is showing as unowned, it may be the case that you can just use the 'disk assign all' command to bring the disk into the controller. It should mark itself automatically as a spare.

Try that and let us know how you get on.


thanks for that.  I now have one spare disc, see the attachment to the post above, but the error persists.  I guess I need another spare disc but they all seem to be assigned?


Hi Guys,

thanks for all your comments, they've helped me to work this problem.

Here's what I did:

I checked Head 1 and found 3 spare disc's (vol status -r) not sure how that happened.  One of the discs was not zeroed.

Made one of the discs 'unowned' with the disk assign <disc> -s unowned -f command

On Head 2 I ran disk assign all to pick up the unowned disc and made it a spare.

I then zeroed both disc's on head 1.

job done.