The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Simulator Discussions

8.2.1RC1 VSIM?

scottgelb

Anyone know when 8.2.1RC1 VSIM posts?  Or if you see it posted please post back here in case I miss it when it is available.

1 ACCEPTED SOLUTION

shatfield

It turns out booting into option 7 is a much faster way to do it.

The only issue there is the default ramdisk used for install is too small for the image.  So I bumped my vm ram to 2gb, then set this bootarg:

setenv bootarg.install.ramdisksize 1024m

From there did a boot into option 7 and the upgrade only took a few minutes.

View solution in original post

19 REPLIES 19

tonacki

The 8.2.1 RC1 Simulate ONTAP images are now available.

Tom

shatfield

In this version, it fails to fdisk a blank ad3 (I usually replace mine and size it for my simdisk load).  Typically if the vmdk is blank ontap will partition it at boot before running makedisks. In this version fdisk fails, even interactively from the systemshell.  The fix seems to be to set kern.geom.debugflags=16, then fdisk by hand to prep ad3. 

shatfield

Have you tried an upgrade?   When 8.2 hit RC it took quite a while to get new VSIMS out so I just upgraded my 8.1.x instances with the RC bits. 

scottgelb

Upgrade tgz for vsim isn't available to resellers.

Sent from my iPhone 5

shatfield

The regular 821RC_q_image.tgz works in the sim.  It may fail due to timeout because the sim is rediculously slow, and it may fail if you don't have a large enough root volume (1gb is not enough).

vSIM80::> system node run -node local sysconfig -av

        NetApp Release 8.2.1RC1 Cluster-Mode: Wed Nov 20 15:25:04 PST 2013

        System ID: 4034389062 (vSIM80-01)

        System Serial Number: 4034389-06-2 (vSIM80-01)

        System Storage Configuration: Multi-Path

        System ACP Connectivity: NA

        slot 0: System Board 2.3 GHz (NetApp VSim)

                Model Name:         SIMBOX

                Serial Number:      999999

                Loader version:     1.0

                Processors:         2

                Memory Size:        1599 MB

                Memory Attributes:  None

        slot 0: 10/100/1000 Ethernet Controller V

                e0a MAC Address:    00:50:56:9e:9c:09 (auto-1000t-fd-up)

                e0b MAC Address:    00:50:56:9e:ca:c1 (auto-1000t-fd-up)

                e0c MAC Address:    00:50:56:9e:e0:e9 (auto-1000t-fd-up)

                e0d MAC Address:    00:50:56:9e:c3:eb (auto-1000t-fd-up)

                e0e MAC Address:    00:50:56:9e:ff:84 (auto-1000t-fd-up)

                e0f MAC Address:    00:50:56:9e:9a:f9 (auto-1000t-fd-up)

                Device Type:        Rev 1

vSIM80::>

scottgelb

Cool. Last time I tried it didn't work and someone gave me a tgz from the vsim build tree. I will try the regular one again.

Sent from my iPhone 5

scottgelb

Times out and won't finish updating image2...enough space but won't complete after downloading the tgz package.  I will create a new 8.2 VSIM and add a lot more disk to aggr0 and see if that helps.

shatfield

Mine timed out on HD, so pushed the vsim over to an SSD and it completed before the watchdog killed the install.

scottgelb

How big is your aggr0 (how many drives did you add from makedisk)? Or did you move vol0 to a new aggr with bigger VSIM drives?

shatfield

It turns out booting into option 7 is a much faster way to do it.

The only issue there is the default ramdisk used for install is too small for the image.  So I bumped my vm ram to 2gb, then set this bootarg:

setenv bootarg.install.ramdisksize 1024m

From there did a boot into option 7 and the upgrade only took a few minutes.

View solution in original post

scottgelb

Worked!  Thank you Sean.  Upgraded from 8.2RC1 to 8.2.1RC1... since I make a lot of VSIM changes (adding disks, config, etc)., much nicer to use the upgrade tgz.

cmode-single::> system image show

                 Is      Is                                Install

Node     Image   Default Current Version                   Date

-------- ------- ------- ------- ------------------------- -------------------

cmode-single-01

         image1  false   false   8.2RC1                    -

         image2  true    true    8.2.1RC1                  12/17/2013 16:42:42

2 entries were displayed.

scottgelb

Tried it on my 7-Mode 8.1.1 VSIM and it upgraded but won't reboot...close but doesn't get it there.  All good though since 99.999% of what we do is cDOT and for transition testing I can use 8.1.1 as the source still... or could try 8.2 as a base and see if it upgrades to 8.2.1RC1 but probably not worth the time.  Screen capture attached.

shatfield

ajay_behera

Can you please share the netapp  link for  8.2.1RC1 sim

scottgelb

Not available yet but we found out we could upgrade the 8.2 VSIM to 8.2.1RC1 from the regular download with a few changes to the env for the boot device then option boot to update software (in the thread)

ajay_behera

Thanks Scott, got the wayout.

dburkland

This information helps a lot, thanks!

Dan

scottgelb

very nice...rebooting now...cross your fingers.  I have fusion snapshots just in case though but hope this works.

shatfield

I have a 4x1gb aggr0 in raidDP, and I expanded vol0 to use ~2gb.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public