Simulator Discussions

CFO - simulator 8.0


I have the simulator up and running on ESX 4.1 - I have installed the CF license, howerver when I run setup I am not asked if I would like to configure as a cluster?

If I run cf status I see see the following message ---- cluster monitor not initialized ----


Re: CFO - simulator 8.0


Hi nsitps1976,

The current Data ONTAP 8.0 simulator does not yet include HA functionality, so you can't configure CF even with the license installed.

The reason is that the Data ONTAP 8 simulator is a much more accurate representation of a physical system than the 7G simulator.  To implement HA, you would need to have two virtual machines that both have shared access to a set of virtual disks and a mechanism to connect their simulated NVRAM cards.  We are currently testing that capability for simulators, but it has not yet been released outside of NetApp.

If HA capabilities between two Data ONTAP 8 Simulator VM's are important to you, could you please describe some of the reasons why and how you plan to use those capabilities in the simulator?  Knowing the use cases will help us prioritize our work.

Thanks and take care,


View solution in original post

Re: CFO - simulator 8.0


Hi Miroslav

Thanks for the response.

This is only for our own education so probably does not rank as high priority!

Do you know if it is possible to add additional storage to the sim, say 100 1GB disks, if so how is this done?

Kind Regards

Re: CFO - simulator 8.0


Hi nsitps1976,

Educating NetApp users is a pretty high priority, and it's one of the main use cases for the simulator so that's already covered 🙂

In terms of adding disks to the simulator: it's possible but somewhat involved.  The maximum number of disks that the simulator can see is 56, and the maximum simulated disk size for Data ONTAP 8.0 is 1GB.  So the answer to your specific question is that you won't be able to add 100x1GB disks.  Or you'll be able to add them, but Data ONTAP won't be able to see more than 56.

I don't have time right now to write up the detailed steps, but the short version is:

1. unlock the diag user account and assign it a secure password (priv set advanced)

2. access the BSD shell

3. cd to /sim/dev

4. add /sim/bin/ to your path

5. use the makedisks command from /sim/bin to add the new disks

6. return to the Data ONTAP prompt and reboot

7. Assign all the new disks to the simulator

The precise commands are a little different for 7-Mode and Cluster-Mode, but the general flow of the process is the same.

Take care and hope that helps,


Re: CFO - simulator 8.0


Many thanks.

Does anyone have the more detailed version (adding disk) they can post here?


Re: CFO - simulator 8.0


Use cases for simulating HA pairs with 8.0;

I would have liked to use the sim with HA pairs to model my environment before touching anything production. (however it probably won't be available before I need to have the new environment carved in stone.)

Also education, as mentioned, but for training my own staff.

My two bits. 🙂


Re: CFO - simulator 8.0


i cannot administer a netapp beyond IT-101 level, but as a data architect (using the v8 simulator) I do want to prove out such as:

Cisco IOS multi-level switches in the cisco simulator, showcasing multi-switch LACP load balancing

Netapp 2-node cluster, with 2 LACP link from each node to the switches, showcasing the proper aliasing of NICs for iscsi multipathing

Vsphere correctly using configuring one or more vmkernel nics on the right subnets on an ESX, to showcase native vmware multipathing really has (a) 2 active paths for different datastores in the same volume, and (b) can failover/failback between active path, as switches and NICs are force-failed.


Re: CFO - simulator 8.0


Hi Miroslav.

I created 28 additional disks with the makedisks command from the systemshell prompt for my ontap 8 simulator.

After I reboot ontap the disks shows up as unowned, but when I assign them they report this error:

Mon Jan 10 14:27:43 EST [raid.assim.disk.nolabels:error]: Disk v5.43 Shelf ? Bay ? [NETAPP   VD-1000MB        0042] S/N [31303055] has no valid labels. It will be taken out of service to prevent possible data loss.

In addition from the aggr status -r all of those disk show up as broken, and haivng a bad label.

Broken disks

RAID Disk       Device  HA  SHELF BAY CHAN Pool Type  RPM  Used (MB/blks)    Phys (MB/blks)
---------       ------  ------------- ---- ---- ---- ----- --------------    --------------
bad label       v4.33   v4    ?   ?   FC:B   -  FCAL  N/A  1020/2089984      1027/2104448

Is there a way to add the disks without having them show up as broken bad label?

Re: CFO - simulator 8.0


Here are the detailed instructions for adding disks to the 8.0 simulator:

Re: CFO - simulator 8.0



Many thanks for the info,

However when I added my extra disks they came up as "Broken" under Storage>Disk on filer view.

I resolved it by unfailing the disks:-

priv set diag

disk unfail -s v6.16

(did this command for every disk that was broken)

priv set admin (when finished)

I can now add them to my aggregate


Re: CFO - simulator 8.0


How do you find the simulator performance wise? I'm testing with Avid Media streaming so am tight in resource already!



Creating Photo Slideshows for you!

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums