Simulator Discussions

How to load Simulator 9.1 in Citrix Xenserver 7.2



August 7, 2017


UPDATE! I now have the simulator 9.1 fully fuctional on Xenserver 7.2 . Network ports and interfaces are available and configurable. I was able to install and configure the sim and it has full funtionality.  If anyone is interested, I will post instructions.




August 1, 2017


Although Xen Project Hypervisor is not supported by netapp simulator 9.1, I was able to load it with limited functionality.

(NOTE: No VM network interfaces will be available to the OS or simulator. I will work on that next. Without network you will only be able to have a one node cluster and CLI admin.)


Citrix Xenserver is a pretty cool enviroment and it is FREE!


These instructions should work with other virtual environments with no floppy support if there are any.


I downloaded and imported the  esx simulator 9.1 .ova file into Citrix Xenserver 7.2  using Xenconsole.  This worked without any problems.  The import sets the memory to 8GB but I changed it to 6.8GB because I only had 8GB on my Xen machine and Xen uses 1GB. I tried 5GB but that caused  a PANIC.


When you start the simulator VM, it will not boot past BTX loader.


This is because Xenserver does not support a floppy disk on guest partitions and the diskx devices found by BTX loader will be off by one number compared to what is defined in the env files as "currdev".


Easy fix: (This expects you to be a proficient unix admin and have a seperate VM with freeBSD installed.)


   1. Shutdown simulator 9.1  VM.


   2. Detach "disk1", position 0  from the simulator VM's storage tab.


   3. Create a new VM and and install FreeBSD if you dont already have one. (Download the ISO from, I used Version 11), install and configure freeBSD  then shut it down.


   4. Attach "disk1" to the freebsd VM at position 1 and start it. The freeBSD VM will have 2 disks. ada0 is the OS boot disk and ada1 is "disk1" 


   5. Login to freeBSD VM as root and run these commands:


     >mount /dev/ada1s1a /mnt

     >vi /mnt/env/env            #Look for currdev and change it's value to disk0s2  , save and exit.

     >umount /mnt

     >mount -t msdosfs /dev/ada1s2 /mnt

     >vi /mnt/env/env            #Look for currdev and change it's value to disk0s2  

                                 #Look for run_vmware_tools and set its value to false

                                 #Make any other changes to environment while your here

                                                                                #Save and exit

     >umount /mnt

     >shutdown -p now


6. Detach "disk1" from freeBSD VM and attach to simulator 9.1 VM at position 0.


7. Start simulator 9.1 VM and it should boot to ONTAP 9.1, press CTRL-C when asked and run option 4.


8. When you see the enable autosupport screen(took about 30 minutes, type exit and you should have the login prompt!


9. You will not have any network interfaces. You can run command line all you want.


10. I hope I can get the network interfaces working. I have some ideas I will post later.





well I'm not working with Xenserver, but with Proxmox.

And offcourse the same floppy problem as well.

I did your advise by changing the disknumber with freebsd.

It boots now further then in the beginning but still a panic before the CTRL-C 


"panic:  must hold domain lock"


I have no idea what that is....

Do you have any ideas?







I found out that the SIM wants to mount root and that failed.

see attachment.

Perhaps there is a work around for that.


The attachment is a VMplayer I used to look where it failed on Proxmox.