The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Simulator Discussions

Installed Sim 7.2.4 Got IP from DHCP but can not communicate

andrew_nomura

Hi,

 

I just installed Ontap Sim on Linux box and everything worked except can not communicate on network..

 

Ontapsim> ifconfig -a
ns0: flags=848043<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 147.85.180.50 netmask 0xffffff00 broadcast 147.85.180.255
        ether 00:50:56:09:e1:96 (Linux AF_PACKET socket)
ns1: flags=808042<BROADCAST,RUNNING,MULTICAST> mtu 1500
        ether 00:50:56:0a:e1:96 (Linux AF_PACKET socket)
lo: flags=1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 9188
        inet 127.0.0.1 netmask 0xff000000 broadcast 127.0.0.1

and

 

It can ping itself...

Ontapsim> ping 147.85.180.50
147.85.180.50 is alive

 

But nothing else,

 

Routing tables

Internet:
Destination      Gateway            Flags     Refs     Use  Interface
default          147.85.180.254     UGS         2        5  ns0
127.0.0.1        127.0.0.1          UH          0        0  lo
147.85.180/24    link#1             UC          0        0  ns0
147.85.180.50    0:50:56:9:e1:96    UHL         0        8  lo
147.85.180.254   link#1             UHL         1        0  ns0
147.85.180.255   ff:ff:ff:ff:ff:ff  UHL         0       26  ns0

 

Ontapsim> ping 147.85.180.254
ping: wrote 147.85.180.254 64 chars, error=Host is down
ping: wrote 147.85.180.254 64 chars, error=Host is down

Your advise is appreciated...

5 REPLIES 5

ALESSIOTORELLI

did you manage to solve this issue?

I have the same problem...

maske

Disable selinux and iptables on the linux box.  Also you can't access the IP of the sim from the machine running the VM.  Setting up the VM nic in promiscuous mode also will help, sorry didn't read that you tried that until now.

ALESSIOTORELLI

Thanks for your answer.

iptables and selinux already disabled.

The nic is put in promisc mode by the simulator when I start it.

It seems the simulator does not respond to arp requests...

ok I managed to solve: we had two nic eth0 and eth1 in bond. If you use a slave nic in the simulator, then it is not capable to communicate. So we modified setup.sh in order to allow the simulator to use bond0 as its nic.

Then it worked

AdvUniMD

If you're running locally (on a workstation for example) you need to communicate with the simulator from another host.

However, pinging outside should work, I don't know what might cause this. Maybe your network card doesn't support promiscuous mode, or the switch discards all packets that it receives from a "forged" MAC address (because that is what the switch thinks it sees)

-Michael

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public