Simulator Discussions

No such file - maytag.L when running simulator on Ubuntu 8.04

egrigson1

I've been running the simulator fine on an old Debian VM, but wanted to move it to my newer Ubuntu host (also a VM). I've setup the host with two NICs (one with a default gateway) etc etc, and running the simulator install (/sim/setup.sh) works fine (using defaults, /sim etc). BUT, when I run /sim/runsim.sh I get an error immediately;

No such file: line 29, maytag.L  

(or something very similar, I'm not in front of the console at the moment)

I'm logged in as 'root', I can see the maytag.L file is there, and set to executable. I thought the simulator came with all required files and no dependancies so that it was portable. Does anyone have any ideas what might cause this? After the error report I'm returned to the console prompt.

Thanks for any help,

Ed.

9 REPLIES 9

danielpr

Please check which directory the runsim.sh is using . It should be pointing to current copied simulator path.

Edit the runsim.sh and check the line for

>>>cd "/x/sim/danielpr/7.2.5"

Change it to the proper path and try running it.

Thanks;

Daniel Prakash

egrigson1

Good thought, I'll check this tonight and see if it helps. I'll post a status tomorrow.

Thanks,

Ed.

egrigson1

Fixed it. It wasn't the path to the file at all, it's because it's a 32-bit executable and the server is 64 bit. I'd checked file permissions which were fine, and command line completion worked so I knew the system could see the file with the correct path. I've now installed the ia32_lib and it runs fine.

Thanks for all the suggestions,

Ed.

jeff_cassianna

BTW... It seems to be ia32-libs for meerkat.

libc6-i386 seems enough on Ubuntu 14.04

paulhar

I'm having the NOW site updated to indicate that the sim doesn't work with 64 bit linux. It's dynamically linked to libraries that aren't included in 64 bit linux builds and at the time I wrote the documentation there wasn't much mainstream use of 64 bit so I didn't think to check it.

Roll on the ONTAP 8 sim... all this Linux pain goes away.


Regards

Paul

adamfox

My first thought is you may have a path problem.  Assuming you are running the script in the same directory as the maytag.L file, try prependin the call with a ./

egrigson1

Thanks for the reply Adam, but it's not that. That was my first thought too, but I've already tried that with no luck. The error message implies that runsim.sh is running, but something at line 29 in runsim.sh isn't found. Looking at the script that seems to be the maytag.L line, but the executable is present in that directory. It's frustrating as I've setup the simulator quite a few times before on a NetApp course, in a preinstalled VM and on a Debian based distro (old v6 though) without issues. I thought getting the networking right was the tricky bit (it's on an ESX host) but now I understand how that works I've hit an earlier snag. Always the way!

Any other ideas or things to try? Anyone?

Thanks,

Ed.

nagendrk

Just to experiment, you could add the complete path to maytag.L in runsim.sh script (if not already present).  Make sure to backup necessary files.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public