Simulator Discussions

Simulate ONTAP 8.1.1 withVirtualBox

There have been a small number of posts both here and in the support community about the change between the 7.3 family of OnTap simulators and those for 8.1.1.  The delivery model changed from being one where you install the simulator on a Linux system (easily setup on any virtualization platform you have) to the model in 8.1.1 Simulator where you download a full virtual machine image designed for use in a VMWare environment only.


Many people will have access to one of the paid options (VMWare Workstation/Fusions/ESX) or can use the free VMWare Player on Windows.  But, for those that need alternatives such as on a Linux or Solaris host platform or something free on a Mac, here are instructions to setup 8.1.1 Simulator on VirtualBox.


Disclaimer:  to date I have only tested this on a single Windows platform.  Specifically, I tested this on a 32 bit Windows 7 host (but on 64 bit capable hardware).  Basic setup and general operations seem normally functional, though I have not delved into all the possibilities that OnTap offers.  The 7-mode simulator is the one on which I did most checkouts since this is what I need to make available to other team members where I work.  I have done minimal setup only on cluster mode.  None of this is technically supported by NetApp, and your mileage may vary.


Test environment:  Dell laptop, 3GB RAM running Windows 7 SP1 32 bit; VirtualBox 4.2.4r81684; Simulate OnTap 8.1.1.  As per the VirtualBox documentation,  you will need a 64 bit processor with virtualization enhancements enabled even if the host OS is 32 bit.


Setup (assumes basic familiarity with VirtualBox)


1.  Download and install VirtualBox.  I just used defaults for setup.


2.  Download the 8.1.1 simulator.  Extract the files somewhere that you want them to be.


3.  Create a new Virtual Machine with OS type BSD, version FreeBSD (64 bit).  Memory required is 1600MB.  Don't select a virtual hard drive now, we need to select a bunch later.  Save the new machine.


4.  Open the Settings for the new VM.  On the System page, Processor tab, set CPU to 2


5.  On the Storage path, delete the CDROM from the IDE controller.  Then, add 4 virtual hard disks to the controller.  For each disk, you will choose an existing disk.  The disks you will add, in order, are "DataONTAP.vmdk", "DataONTAP-var.vmdk", "DataONTAP-nvram.vmdk", and "DataONTAP-sim.vmdk".  Finally, add a Floppy controller with a single, empty floppy drive.  When complete, the storage setup for your new virtual machine should look like:


6.  On the audio page, uncheck "Enable Audio".


7.  On the network page, you can add up to 4 network adapters in any style that you choose - host only, bridged, internal, NAT.  This provides a bit more choice than available through VMWare Player.  Having some NICs of each type certainly can setup some interesting possibilities for multiple simulators.  For each NIC you add, expand the "Advanced" section for the NIC and select "Intel PRO/1000 MT Server (82545EM)" as the adapter type.  The Simulator virtual machine only has drivers for this emulated NIC type.  A sample NIC setup would look like:


8.  The default setup of the VMWare virtual machine attaches a local Windows pipe as a conduit to each of two serial ports - one for the "console" and one for debugging.  You can enable serial ports and redirect, but it is not required.


9.  On the USB page, uncheck "Enable USB Controller".


10.  On the Shared Folders page, no shared folders need be created.


11.  Save the virtual machine.


12.  Be sure you have 1600MB real free memory to start the guest or it will fail during startup at some point.


13.  Start the virtual machine.


14.  During the 10 second countdown, click in the VM and press any key that is NOT Enter to stop the boot.


15.  Update the environment to not start the VMWare tools with command "setenv bootarg.vm.run_vmtools false"


16.  If you are installing a 2nd simulator this is a great time to update the serial number as per the documentation as well.


17.  Enter command "boot" to continue with the startup of Data OnTAP.


18.  When the "Press Cntrl-C for menu" appears, press Cntrl-C and wait for the boot menu.  This first boot can take a little bit to happen depending on your hosting platform.


19.  On the boot menu, select option 4 and confirm clearing all disks and deleting all data.


20.  The Simulator will restart - let it proceed normally.  After restoring a fresh Data OnTAP from the simulated media you will eventually get the prompts for standard setup of a new Filer.




Re: Simulate ONTAP 8.1.1 withVirtualBox


I am trying to install ClusterMode 8.1.1 sim on VirtualBOx v4.2.4

I have download the Netapp sim - bit it contains only 2 files (DataONTAP-flat.vmdk , DataONTAP-nvram-flat.vmdk) , and 1 directory (cfcard/env/env file).

I define BSD 64bit VM, but when i try to import the vmdk files i get the following error:

Failed to open the hard disk C:\vsim-cm1\DataONTAP-flat.vmdk.

Could not get the storage format of the medium 'C:\vsim-cm1\DataONTAP-flat.vmdk' (VERR_NOT_SUPPORTED).

Result Code: VBOX_E_IPRT_ERROR (0x80BB0005)
Component: Medium
Interface: IMedium {29989373-b111-4654-8493-2e1176cba890}
Callee: IVirtualBox {3b2f08eb-b810-4715-bee0-bb06b9880ad2}

Please advise...

Re: Simulate ONTAP 8.1.1 withVirtualBox


I have the same problem. Further, the "setenv" command seems to do nothing. When I hit a random key during the initial startup, I am sent to a prompt:

FreeBSD/i386 boot

Default: 0:ad(0,a)/boot/loader


When I enter "setenv bootarg.vm.run_vmtools false" at this prompt the response is:

FreeBSD/i386 boot

Default: 0:ad(0,a)false


If I type "boot" at this prompt the response is:

No boot

FreeBSD/i386 boot

Default: 0:ad(0,a)boot


Any ideas appreciated.


Re: Simulate ONTAP 8.1.1 withVirtualBox


Thanks for this guide.  Can you upload a guide to setup the cluster mode setup for on tap on the virtual box - I could do with you clarifying what network adaptors work best and how we get the 2nd node to join the cluster.  Thanks

Re: Simulate ONTAP 8.1.1 withVirtualBox

I'm getting the same error as well. Anyone found a solution to this yet?

Re: Simulate ONTAP 8.1.1 withVirtualBox

I managed to get the disks attached. My problem was that I had only ensured the 4 VMDKs mentioned were in the VMs directory. Once I added all the VMDKs from the archive, I was able to add the disks

Re: Simulate ONTAP 8.1.1 withVirtualBox

I followed the guide to the letter (the second time around) and got as far as step 17. Unfortunately the VM then goes into a reboot loop, but I neve rsee the "ctrl-c" menu to reinitialise the simulator.

Any suggestions ?

Re: Simulate ONTAP 8.1.1 withVirtualBox

which data ontap image are you using, the ESX one or the fusion/player/etc image ?   Or does it even matter ?

Thanks for the nice write-up,


Re: Simulate ONTAP 8.1.1 withVirtualBox

I was using the Fusion/Player version. Can't confirm whether the ESX one

would make a difference, but I suspect that it should be close enough.

Bob Greenwald

Enterprise Storage | HSBC Technology & Services N.A.

26525 N. Riverwoods Dr, Mettawa, IL

T +1.847.739.9524

From: daniel_mack <>

To: Robert C Greenwald/HBUS/HSBC@HSBC02

Date: 02/11/2013 03:17 PM

Subject: - Re: Simulate ONTAP 8.1.1 withVirtualBox

NetApp Online Community

Re: Simulate ONTAP 8.1.1 withVirtualBox

created by daniel_mack in Simulator - View the full discussion

which data ontap image are you using, the ESX one or the fusion/player/etc

image ? Or does it even matter ?

Thanks for the nice write-up,


Reply to this message by replying to this email -or- go to the message on

NetApp Community

Start a new discussion in Simulator by email or at NetApp Community


This message originated from the Internet. Its originator may or

may not be who they claim to be and the information contained in

the message and any attachments may or may not be accurate.

Re: Simulate ONTAP 8.1.1 withVirtualBox

Sorry, but I've downloaded several different 8.x versions of the simulator, and I can only see the following vmdk files:




DataONTAP-s001 (through -s024).vmdk

I simply have never seen DataONTAP-var.vmdk, -sim.vmdk or -nvram.vmdk. Am I missing something?

If I try and load Any file other than dataONTAP.vmdk I get the same error message as shown above in yard's original response.

Most frustrating -- what am I missing here?