Simulator Discussions

Simulator 8.0.1 in KVM




i am a Unix/Linux Specialist and i run Linux on my notebook and our prefered virtualisation is KVM.

I am able to boot the simulator under KVM, the only thing that is not working are the NICs; my KVM is passing 4 e1000 NICs to the simulator but he does not recognize them althoug VMWare is passing the same hardware.

I know this is not supported, but it would make my life much more easier; i have to run my Windows that i need to administrate the simulator in a KVM VM and KVM and VMWare cannot run both at the same time on one system.



Same question, but for Xen, did anyone manage to run 8.0.1 on Xen?



That should be the same issue; if you use Xen in HVM Mode then it uses also the qemu-device-model, the same as KVM.


Hi folks,

The short answer is that the DOT8 simulator expects specific identification and behavior from the underlying virtual devices. If you can get KVM and Xen to provide virtual devices that look and act exactly like in VMware, then there's a good chance that it will work. I know that a bunch of people have tried with Hyper-V without much success. If you get simulator to boot and get configured in KVM, then that's already good progress. Does KVM provide options for fine-tuning the virtual NIC type? If so, perhaps by playing with those options you'll hit on a combination that works. The simulator engineering team has their hands full and isn't going to be doing any development and testing related to KVM and Xen any time soon, so it's entirely up to the KVM/Xen experts on this community to figure out what's possible.

Take care and hope that helps,



Lot of time has passed here...was there any progress? I'm just about to give it a try with DOT811...

: can you at least specify what is the "specific identification and behavior from the underlying virtual devices" ?



I believe that the PCI IDs for the virtual E1000 intel NICs are different. ESX emulates a device with PCI ID  8086:100f, KVM uses something different (I'm not at home ATM, I can't look it up right now).  I suppose that the ONTAP NIC driver binds only to those PCI IDs used by ESX, not those used by KVM (or XEN, they both use QEMU for device emulation).

AFAIK there is no way to tell QEMU which PCI IDs to emulate.  You would probably have to patch the source code.


😐 considering we want to run within OpenStack Cloud, patching source is not really an option. thanx for info anyway.


I've been digging into this somewhat after I read this and I'm not quite sure but the following from

Note that there are other device options to select alternative devices, or to change some aspect of the device. For example, you want something like: -device DEVNAME,netdev=NET-ID,macaddr=MACADDR,DEV-OPTS, where DEVNAME is the device (e.g. i82559c for an Intel i82559C Ethernet device), NET_ID is the network identifier to attach the device to (see discussion of -netdev below), MACADDR is the MAC address for the device, and DEV-OPTS are any additional device options that you may wish to pass (e.g. bus=PCI-BUS,addr=DEVFN to control the PCI device address), if supported by the device.

Seems to indicate that it is possible to 'control the PCI device address'.



Unfortunately, I wasn't talking about PCI addresses, but about PCI IDs.  A PCI ID is an unique identifier to a specific brand of PCI card (for example, an Intel E1000 NIC). You can see them in the output of "lspci -n", or a list of a whole lot of them in /usr/share/misc/pci.ids or at Sometimes, different revisions of the same brand get a new PCI ID, which happened to the Intel E1k.  So VMware emulates E1k NICs using one PCI ID, and KVM uses another.  The only way to change that is to change the source code (see the files hw/net/e1000.c. include/hw/pci/pci_ids.h and include/hw/pci/pci.h in Qemu's git repository at

That would (probably, never tested) make Ontap's e1k driver recognize the device.  If the emulated device then still talks the way the driver expects (because it is actually meant to talk like a different device) is a different story altogether. It _might_ work, if the two kinds of e1k NICs are similar enough, but you just as well might get weird errors, lockups, random packet losses, whatever.


FWIW, VirtualBox uses the same 82545EM / 8086:100f device that VMware uses and it at least booted up to the password prompt when I tried it.

qemu-kvm would be way way way better though, I'll try your idea of hacking the ID in the source and see what happens.


Just in case folks are still interested in this topic, I applied the patch to the qemu sources from here:

Since I wasn't able to find a downloadable version of the patch, I copy-pasted it and had to adjust a number of lines so the patch could actually be applied, which was a bit tedious, but what matters is the end result.

Which is: it seems to be working fine for a linux guest - but the ONTAP simulator still doesn't like it, as the next screenshot illustrates.

Might have to do with the comments on the patch code in the follow-up post of the thread:

I too would prefer to see the simulator running on KVM, but at this point I'm inclined to stick with virtual box, where it's working fine for me.

Of course, should anybody manage to get this to work with KVM, please share.




Hey, this is an old thread which I'm sure no oen will read --but I got an OnTap 9 .4 Simulator built and fully functional in KVM using a Centos 7.

To be honest, I did not expect it to work for such a small effort I put into it.







that sounds very interesting, I am about to try that myself. 

Could you describe how you did it? 


Many thanks. 


please share your details how you got 9.4 Simulator running in KVM




Has any thought or progress been given/made to getting the simulator running in KVM in the last year or so?

With KVM picking up speed and OpenStack deployments growing this seems like a natural thing to make happen.