Simulator Discussions

simulator using KVM


hi there,

has anyone managed to get the ontap simulator running in KVM? (on linux)




I've tried, not not successfully yet.

It boots, but the console is reverting back to serial.



Could you perhaps describe how you got it to boot? I'm stuck with the multi-image VMWare install, don't have a clue how to import this into KVM




I created my sim using the vsim make tool on the internal cycl servers, so it may be different than yours. The tools created 3 vmdks for me and disk-1 is 1.1GB and is the boot disk.  The following command line boots the VM, but it crashes quickly.

qemu-system-x86_64 -hda 104/vm-104-disk-1.vmdk

If you can figure out which is the boot disk for your sim in ESX, just try the command above with -hda path_to_boot-disk.vmdk


Oh okay, yeah I got that far myself. I believe it may be crashing because it expects 3 disks at bootup time. The 3 vmdk's may be those three disks and I think  you may have helped me a bit further, I might need something like -hda ...-disk-1.vmdk -hdb ...-disk-2.vmdk -hdc ...-disk-3.vmdk. Going to give that a try when I come home this afternoon.


Yes, DOT will need at least those 3 disk. However when I give it hba-b-c it still crashes, love to see if you can get further.

The most promise I've seen is from trying it from Promox (, where it got as far as switching to serial console (where I lost access) but the VM seems to be still running. Haven't had time to figure out how proxmox gets further and haven't looked into this for months.

I also wonder if setting the SIM up under ESX, setting the IP for the mgmt IP, adding aggrs etc. and then rebooting via kvm would get around not having serial port access.


Well I installed VMWare player here in the office just to give it a try and I noticed that doesn't quite work as flawlessly as I hoped either. I had to manually own all the disks (not quite sure about the right terminology here) to get it to start properly and even then I didn't appear to have a network connection which is why I'm trying to install it on my laptop. VMWare player appears to have some networking issues it seems and by not being able to tweak the NIC's getting the sim to run completely is not trivial, definitely not for somebody who's beginning to learn more like myself.

The thing that apparently hampers KVM the most is that the PCI ID's that KVM reports to the sim are not what it expects to see (eg. not the same as what ESX reports). One person on another forum about this subject said that PCI ID's cannot be tweaked, but I now have reason to believe that this is in fact possible, so that's another path you might want to consider (eg. get it to run on ESX, jot down the PCI ID's of the NIC and try if you can get KVM to pass on the identical PCI ID). Another try may be simply to switch the NIC from 'default' (for KVM the RTL8139 NIC), to the e1000 (default in qemu and therefore conceivably also in ESX?)

Just a few ideas I'm tossing around.


Resurrecting old threads is fun!

I convinced the QEMU network maintainer (stefanha you are a rock star) to hack their e1000 driver to also support the e1000 model that the simulator uses (82545 instead of 82540) -- without this it will complain that there are no network devices.  Please let me know if you want the patch, I was able to apply it to the ubuntu 13.04 qemu-kvm packages.  Hopefully it will make it through the qemu release process and into a future release.

However, the bootup rc files are still not happy about something since it ends up hanging.  I haven't had time to look closer, but if anyone wants to work on it please let me know.  I think it is very close at this point.



Mark, great progress.

Where can folks get the QEMU patch? and a short guide on how to patch and what to patch would be great.


Hi Mark,

can you provide the patch? I would be happy to take a look at it...


NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner