Software Development Kit (SDK) and API Discussions

Volume list collection failed



I am having trouble collecting list of volumes on a C-dot system. I tried volume-get-iter and it returns as passed with 0 records. Also the same problem with perf-object-instance-list-info-itr. Below is the output I am seeing.





Re: Volume list collection failed

Remove the empty query, or provide some sort of value to query by, from the ZAPI call.  Also, you'll want to remove the "desired-attributes" section as well...leaving it out, or with no "volume-attributes" section, will cause it to return all data (assumign that's what you want).  With what you have in the ZAPI I believe it will only return the volume name and UUID.


Using simply "<volume-get-iter />" will return all volumes and all attributes.


<netapp xmlns="" version="1.30">


If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Re: Volume list collection failed



Thank you. It worked.

Cloud Volumes ONTAP
Review Banner
All Community Forums