Software Development Kit (SDK) and API Discussions

cifs shares for vfiler




In Ontap 1.8 api it shows that cifs-share-list-iter-next is enabled for vfiler.


But when i query for the command i don't get the vfiler cifs shares.


I get the vfiler shares information when i run the system-cli command vfiler run vfilername cifs shares.


Am i missing something?


Ontap version isNetApp Release 7.3RC1,

SDK- Java-manage-ontap-sdk-3.0






Hi All,

I just ran into the same problem.  I am writing an app using SDK 3.5P1 and C#..  It's a simple app.  I get the list of vFilers, then loop through the list (using s.SetVfilerTunneling(vFilerName); ) to get the CIFS share, NFS exportfs and qtrees for each vFiler.  I set the vFiler to vfiler0 and all works fine.  As I go to each vFiler, I get the error " -Error- 13001 Unable to find API: cifs-share-list-iter-start for vfiler xxxxx"  As the loop continues, I get the information for NFS and QTrees.  As I switch to the next vFiler, the same thing happens

Thank You,


A little more info:

Login style is RPC (haven't tried Login_Password yet)

transport is HTTPS (not allowed to use HTTP)

Filer running 7.2.3 ->


Hi Andy,

cifs-share-list-* APIs are not enabled for vfilers running on 7.2.3 ->


Thank you for your reply.

Is there any way that the documentation can state what version the API works with or started to work with?  I saw in a thread that there is a link to where this is kept on the NOW site.  I'll have to find that thread again and bookmark it.  To have to double check the matrix to see if the API will work can be a bit cumbersome.

Thank You,



cifs-share-list-* API support for vfiler is enabled from 7.3 release onwards. You can refer  vfiler enabled API reference sheet from the following link:


Hi Aravind,

In API documetation, if Vfiler-enabled is set to Yes, it means that you can issue the API to vfiler aswell.

It seems that you are issuing the cifs-share-list-iter-* API request to physical filer but not to the vfiler. You should issue the API directly to the vfiler to get its CIFS share information.


Hi Ram,

I tried issuing the command on the vfiler ,but i get unable to connect to the host error message.

<results reason="Can't connect to host (err=10060)." status="failed" errno="10060"/>

I also tried pinging all the vfiler ips returned by the vfiler-list-info command,but none of them were reachable.Any idea as to what might be the problem.



check the the status of the vfiler and its netmask is configured properly.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner