Software Development Kit (SDK) and API Discussions

na_elementsw_check_connections module can't connect to solidfire cluster

travisen

Hello!

 

I am trying to automate the creation of volumes and other things on a solidfire cluster by using ansible 2.8.1. I have been unable to get the na_elementsw_check_connections module to succesfully connect to the cluster. The solidfire cluster gui is available and I am able to login to it. I am using the same user to login through the GUI and in the ansible playbook.

 

Here is the full error I get:

 

fatal: [localhost]: FAILED! => {
"changed": false,
"module_stderr": "2020-01-28 18:17:26,801 - solidfire.Element - INFO - {\"params\": {}, \"method\": \"GetAPI\", \"id\": 0}\nTraceback (most recent call last):\n File \"/home/tn8562/.ansible/tmp/ansible-tmp-1580235446.35-134874022480101/AnsiballZ_na_elementsw_check_connections.py\", line 114, in <module>\n _ansiballz_main()\n File \"/home/tn8562/.ansible/tmp/ansible-tmp-1580235446.35-134874022480101/AnsiballZ_na_elementsw_check_connections.py\", line 106, in _ansiballz_main\n invoke_module(zipped_mod, temp_path, ANSIBALLZ_PARAMS)\n File \"/home/tn8562/.ansible/tmp/ansible-tmp-1580235446.35-134874022480101/AnsiballZ_na_elementsw_check_connections.py\", line 49, in invoke_module\n imp.load_module('__main__', mod, module, MOD_DESC)\n File \"/tmp/ansible_na_elementsw_check_connections_payload_NwscKY/__main__.py\", line 152, in <module>\n File \"/tmp/ansible_na_elementsw_check_connections_payload_NwscKY/__main__.py\", line 147, in main\n File \"/tmp/ansible_na_elementsw_check_connections_payload_NwscKY/__main__.py\", line 96, in __init__\n File \"/tmp/ansible_na_elementsw_check_connections_payload_NwscKY/ansible_na_elementsw_check_connections_payload.zip/ansible/module_utils/netapp.py\", line 137, in create_sf_connection\nException: Unable to create SF connection\n",
"module_stdout": "",
"msg": "MODULE FAILURE\nSee stdout/stderr for the exact error",
"rc": 1
}

 

 

There looks to be a proxy / ssl issue which I am not sure is related to the above error as I do not see mention of either in the above module's error:

 

$ wget --no-check-certificate XXXX
--2020-01-28 18:47:43-- http://XXXX/
Connecting to XXXX:XXXX... connected.
Proxy request sent, awaiting response... 302 Found
Location: https://XXXX/ [following]
--2020-01-28 18:47:43-- https://XXXX/
Connecting to XXXX:XXXX... connected.
Proxy tunneling failed: Service UnavailableUnable to establish SSL connection.

Connecting to XXX.XX.XX.XX:XXXX... connected. 

Proxy tunneling failed: Service UnavailableUnable to establish SSL connection.

 

 

I appreciate the help.

 

Travis

0 REPLIES 0
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public