Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

Can't register VSC

jmerene8778

I keep getting error

Registration failed with the following message: NVPF-00001: Invalid vSphere credentials: sfesxvc2.advent.com:443 - . Reason: java.lang.NullPointerException

Verified the username and password are correct.  The password doesn't contain "&", "<", or ">"

any thoughts?

6 REPLIES 6

CARLOSCUNHA

I have the same message and I tried this resolution but it failed again.

Tried with other users but the same error appears.

I have restarted the machine , both vcenter and VSC but the problem persists.

Is there any solution to this problem.

FWEBER_ARXES

Hey anyone,

is there a solution for this problem out now?

I have the same issue at a customer side 😕

The interesting thought here is, what prerequesites to the user account and password do exist to register VSC (4.1 in my case)?

We tried to register with a service account (no group policies and such attached) and it is not working.

On the other hand registering with a regular user account with policies attached registration just works fine?!?

Thanks alot

Frank

thomasdorsch

Hello folks,

since this morning we have a similar issue with vsc 4.1 and vCenter 5.1 U1.

The last smvi backup runs fine at 4 am. The next one at 5 am did fail. Username/Password issue was recorded in windows event log. If i try to reregister the plugin it also fails:

Registration failed with the following message: NVPF-00004: User name DOMAIN\USER and the password specified for the vCenter server are not valid.  Please try another user name and/or password

The account is valid and the password correct.

Nothing changed so far, what's going on here?

Any hint is highly welcome!

Thomas

richarde

Try to apply your permissions at the top level (vCenter Server not sites or clusters underneath) for the account you are using to register. Make sure propagate is checked.

Respectfully,

Rich Evans

STORAGE_JANITOR

Was there a need to keep version 2.1?  I believe VSC 4.0 is out, we just upgraded it a few days ago.  Now it supports VMDK alignment live (reboot needed) and VAAI for NFS, just to name a couple.

didnt realize there is 4

ok so i installed 4, registration went fine, but when launching the vsphere client i don't see that netapp tab, is there any way of verifying on the Virtual Center server that it registered correctly?

Also when i go back to https://localhost:8143/Register.html to re enter credentials i get the following error

Error getting registration information: NVPF-00007: Could not retrieve registration information: com.netapp.nvpf.client.vsphere.CredentialServiceException: NVPF-00005: Could not retrieve credential information: java.lang.NullPointerException

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public