VMware Solutions Discussions

Insight Balance error: Could not complete login to this storage array because of an incorrect username or password

fletch2007

Hi,

We are running v 3.6 of Insight Balance - its connected fine to our vCenter and discovered most VMs.

But when we attempt to Discover->StorageArrays -> Add Storage Array

and provide the IP and credentials the response is always

"Could not complete login to this storage array because of an incorrect username or password"

The login is the same that works for direct SSH

The netapp arrays are on the same subnet as Insight Balance (no firewalls blocking)

Anyone offer advice?

thanks

http://vmadmin.info

2 REPLIES 2

fletch2007

Our password has a '&' (Ampersand) character in it.

On a hunch I temporarily set the passwd to a version without the '&' and Insight Balance logged in and discovered with no issues.

At this point this seems like a bug in the parsing/passing of the password string by Insight Balance.

thanks

madden

I'm having the same problem you had with my controller running 8.0.2P1 and noticed in the config guide it says:

So according to the docs your '&' should have been ok.  Anyway, I set a username/password that has no special characters whatsoever and I still get the same error.  I checked a packet trace and it looks like login is actually OK and a few API call/responses are occurring.  Login with another netapp, not invovled with virtualization and running 7.3.6 and it succeeds. 

Any suggestions?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public