The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

Issue installing NFS Plugin for VAAI on Virtual ESX hosts



I'm having an issue with installing the NetApp NFS Plug-in for VMware VAAI v1.0 on my ESXi hosts.  I have a virtual ESX environment - meaning the ESXi hosts are actually virtual (which may be the issue).  We designed a way to quickly stand up virtual ESX environments and we're using one to do some initial VAAI linked clone testing.  The environment is ESX 5.1, DOT 8.1.1 7-mode, VSC 4.1 and eventually NFS Plugin 1.0.

I'm able to get VSC installed and I've copied the .vib plugin file to the correct location.  So it is listed correctly in the tools section of the VSC console but when I click to install to hosts my (2) virtual ESXi hosts are grayed out as incompatible.  I've also tried installing at the esx cli with the offline bundle but it just hangs and never installs.

What I'm hoping to glean is what check is VSC performing (when using the gui) to determine the compatibility of an ESXi host for the NFS Plugin?  This might help me determine if the issue is indeed due to testing with virtual ESXi hosts or if I've got a port blockage somewhere or something else I don't know about yet.  Thanks!




Not 100% true.

I'm the TME for the VSC, and I have confirmed with development that there are two checks that happen when you hit "Install" within the NFS VAAI section...

  1. ESXi 5.0 or greater
  2. ONTAP 8.1.1 for 7-mode, 8.1 for Clustered Data ONTAP

Is it a "supported" configuration?  No.  But it should work, and we have done so many times in lab environments ourselves to write documentation and record demo's.

For what it's worth, I recorded this demo in a nested ESXi config: 


Wow, thanks for the update Nick!  What I wrote above is what I was told by support per case # 2003982902 - the gentlemen I was working with said they tried it themselves and couldn't get it to work either.

In my case, the virtual ESXi hosts were v5.1 and the array is running DOT 8.1.1 7-mode - this is a lab environment so I certainly wouldn't do this in any other environment but for initial functional testing it adequate even if not supported.  So I'm not sure where the disconnect was but now that you've confirmed the checks that VSC performs that may be the issue.

Can you specifically tell me how VSC performs these checks?  In our environment It must be either unable to communicate with the array or our virtual ESXi v5.1 bundle has a config issue but this info would help me check.  Thanks again.


Looks like I had VSC credential issues with the storage controllers.  I cleared that up and it's working now - thanks!


It showed as grayed out until I enabled SSH/console in ESXi 5.1U1.  It still shows gray on the ESXi hosts I did NOT enable SSH/console, so that seemed like the fix for me!


Actually it might have been something else and just a coincidence because my other hosts were already SSH/console enabled, but ESXi 5.1.  Maybe because they don't have a VAAI compatible storage controller yet.. they don't show up.  (I am testing it on two systems before I roll it out, so the other hosts don't have VAAI enabled controllers yet).  So that could be the case or maybe it was a combo of the two.

Ah the fun of variables in troubleshooting!


VSC should be creating a log file when it iterates over the compatible hosts.    I say should because I don't have access to the source code right now to look for the specific log file.   Since VSC enables the VAAI options on the controller, it requires a compatible controller to be attached before it allows the plugin to be installed.   The hosts will be disabled unless a compatible controller is found.    With that, ensure that all your controllers have been discovered.


Good deal.   One of the advantages of using VSC to install the NFS VAAI plugin is that it will configure your host as well as set the proper settings on the connected storage controller.   But, in order to do that, VSC needs to have previously discovered the controller.   From your experience, it sounds like VSC needs to provide some better messaging when the controller has invalid credentials.    Thanks for bringing this to our attention.


That'll do it!  Glad you got it resolved!


Per NetApp support this is not a supported configuration and will not work.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner