VMware Solutions Discussions

Problem adding storage with VSC 4.2 and vCenter 4.1 (build 925676)


Hi There;

I'm a NetApp newbie.  We're formerly a HP EVA storage environment , and now migrating to an HA pair of Netapp v3240's. (Ontap 8.1.3 7-mode)

From within VSC (on a XP client), I'm trying to add the NetApp storage but having some issues, and finding it VERY frustrating.

There doesn’t seem to be a lot of consistency within the Plug-in GUI.  When we install VSC and are trying to add the NetApp controllers,

are we doing it from the Datacenter object, or the Cluster object?  Does it matter which?

The reason is that I see two COMPLETELY different “Overviews” of controller status when I switch back and forth from the VMware Datacenter to the VMWare Cluster. 

Not only that  It still shows as “updating” long after the Netapp Storage Discovery has completed.

One controller is "somewhat there", but status indicates "?unknown"

I’ve setup SSL a few times in onCommand System Manager and re-tried adding the controller.

Also it’s showing as my two ESXi hosts as being “Non-compliant”.  What does this mean?  We don’t use Host profiles.

In VSC when adding a storage system, sometimes it takes forever to come back with anything (verifying credentials). Sometimes I get the "controller privileges popup" for the account being used,

sometimes, I get "the hostname:port# cannot be resolved", using either the IP or the FQDN.

The Vmware and Netapp systems are on the same subnet. I can ping the Controller management IP's, and their respective DNS names from the vCenter server.

I can Putty into the SP's no problem. In onCommand System Manager everything looks ok, using the same management IP's as I am with VSC.

I've uninstalled/reinstalled VSC several times now, and am at a loss as to what the problem is.  

Any Ideas?





With vCenter 4.1, running VSC 4.2 requires vCenter to be at 4.1u3 per the Interop Matrix (IMT); I'd ensure first off that you've got vCenter 4.1u3 installed to avoid any known issues with the SDK/API.

In addition, it's much easier when adding controllers/modifying "overall" settings, when you click on "Home", then "NetApp", then go into Provisioning and Cloning from this context.  This will give you a better context and allow you to manage all of the controllers and their resources for datacenters/clusters/etc.  Also keep in mind that for Provisioning and Cloning to function, you will need the controllers added under Monitoring and Host Configuration, and to ensure that everything is functioning correctly I'd recommend ensuring they're added using the root (7mode) or admin (clustered data ontap) credentials.


Hi Shrie;

We're at build 925676, which is U3a (see http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&externalId=1014508)

and yes we're using root to try adding the controllers from Monitoring and Host Config. This is where I run into the authentication issues, among other strange occurances.



Message was edited by: Gregg Dow ps - I have confirmed the Controller credentials with the OnCommand "Network Configuration Checker". 


Lets go ahead and get a support case opened for this so we can look through the logs, I just pinged you offline with the directions