VMware Solutions Discussions

Removing an unlisted backup job


We added new NFS datastores into our newly upgraded VSphere 5.1 / VSC 4.0 environment and attempted to set up scheduled backup jobs. Discovered that we had to re-ip the new datastores, and subsequent attempts to add the scheduled backup fail with the error: "Failed to create the backup job. Reason: The backup or job name "jobname" already exists. Names must be unique. "

The job in question is unlisted in the Backup and Recovery tab, I know I could add the job with a different name, and probably will, but I am curious how to remove the existing yet missing job?

Thanks -




I found a solution in this thread: https://communities.netapp.com/thread/8473

- stop the NetApp vSphere Plugin Framework service,

- stop the NetApp SnapManager for Virtual Infrastructure service

- copy the %install%/smvi/server/repository/backups.xml file

- use wordpad and edit the same file

- remove the backup entry/ies starting from the "<backup uuid="" tag through to the </backup>

     (may look like "<backup mounted="false" uuid=.....> )

- restart the SMVI and NVPF services

NetApp Alumni

Steve, the steps you posted would change or remove backup entries and will not solve issues with backup jobs. Additionally, it is not recommended to edit the XML files directly. The right way to resolve your issue would be to edit backup job definition. Looks like missing backup jobs is real problem here. Do you remember what change made the backup jobs disappear?


The job was never listed in the console – while creating the job it always failed to list the virtual entities available for selection, and I had to cancel.

I am assuming this was because the ip address we used for the new datastore was already in use in another area of the country. So, it was a separate datacenter, both separate private networks, but both existing on the same virtual center and that must be what choked the new backup job creation, or at least stopped it right after recording the job’s name.


Thanks !!!



I had a similar problem. One of my customers is using SMSQL against NFS volumes.

Without reason SMSQL started having trouble backing up the SnapInfo volume. I wasn't able to create new snapshots using named sqlinfo__XXX__recent using SMSQL / SnapDrive. I just got an error telling me that the snapshot name already existed. It didn't on the filer / SnapDrive / SMSQL.

I tried almost everything including reinstalling SD/SMSQL but nothing worked until i found this post. The problem I had looked like this:

The complete operation list is shown as follows
Server Name: *********************

1. Preparing LUNs for Snapshot copy creation

2. Creating a Snapshot copy for the LUN

3. Creation of backup (sqlinfo__XXX__recent) failed.
 Reason: (The backup or job name sqlinfo__XXX__recent already exists. Names must be unique.).

When editing the XLM file I found an entry with the snapshot name. The status of the job was u"running". Deleting this entry solved the problem.