VMware Solutions Discussions

Resizing a VMware Datastore



I am using the Provisioning and Cloning functionality of the Virtual Storage Console to resize a VMware datastore.  I select the datastore to be resized and select reszie, I get a screen allowing me to enter the new size of the datstore, currently it is 300GB and I am attempting to increase it to 500GB.  It shows maximum datastore size as 2,047GB.  I then get an error message when it attempts to resize the datastore as follows:

Request to grow volume 'volname' failed because the resulting volume size is greater than the maximum size.  Select a seize of at most 14.3TB. (errno=13114)

Any idea how to fix this problem?




What version of the software are you using?  Have you tried this on the latest (VSC 2.1)?

Could you please post a screen shot of the resize window, or share with us more details about your datastore?


// David


Using VSC 2.0.1.  As I am using IBM N Series this is the latest available.

Attached are screenshots of the resize window and the generated error message


Have you tried resizing from the controller CLI?


Yes, I can do it manually from the controller and this is how I normally do it but the customer I have installed this solution for would like to use the VSC to make the storage administration easier.


Have you tried it specifically for this LUN?  The error being reported is an ONTAP error message.

And what was the original size of the LUN?  LUN geometry limits the maximum resize allowed based on the initial size of the LUN.


Today I have created a new datastore in a new volime using the VSC with a size of 100GB, VSC is configured to create the volume 20GB bigger than the datastore.

I have then tried to increase the size of this datastore using the VSC and still get the error above.  I can increase the size of the volume using System Manager and then increase the size of the LUN (again in System Manager) and then increase the size of the datastore.  But I should be able to do all of this with VSC by just specifying the new datastore size and let it resize the volume, LIN and finially the datastore for me.

I have done the same by trying to resize a datastore with VSC and when it fails with the message in my original post on this subject I can increase the volume and LUN at the command line and then increase the datastore with teh vSphere Client.


Could you open a support case with NGS so we can see the logs?  Thanks.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.