VMware Solutions Discussions

SRA 7.2.1P1: VASA Provider and SRA: Not running

MrLe

My Site recovery manager failed with Storage Replication Adapter -  Array Pair error: "Array Not Found"

ON SRA, 

Application Service Status
--------------------------
Virtual Storage Console: Running
VASA Provider and SRA: Not running

 

When I try to start the service, command failed with error message.

Job for vpserver.service failed because the control process exited with error code.
See "systemctl status vpserver.service" and "journalctl -xe" for details.
Command failed.

How do I run those commands above? and with which credentials?

My environment:

vCenter 6.7

SRM 8.1

SRA 7.2.1P1

Thanks in advance.

Giao Le

3 REPLIES 3

Ontapforrum

Not sure about the error, but you can try this for logging into diag shell(for running commands):

 

To "log in" take a look at this kb: [User=maint]

1) Connect to the virtual console of the appliance using the vSphere web UI of your choice.
2) Log in as the "maint" user.
3) Choose "Support and Diagnostics"
4) Choose "Access diagnostic shell"

 

https://mysupport.netapp.com/site/article?lang=en&type=solution&page=%2FAdvice_and_Troubleshooting%2FData_Storage_Software%2FVirtual_Storage_Console_f...

 

MrLe

Thanks to the link.

I am able to use the Diag shell and check for status of services and logs.

I can see the process id 

Looks like vpserver_watchdog tried to restart the vpserver.service and failed, because process is already running.

SRA function is working and I don't use VASA Provider, so I am ok for now.

May be time for upgrade to new version.

Regards,

Giao

 

 

 

Ontapforrum

Nice to hear that. As long as it's working and you don't use VASA then let it be.  Sometime upgrade helps, so may be you should consider that.  I can't really suggest anything more as knowledge is very limited here.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public