VMware Solutions Discussions

Snapdrive problem after ESXi upgrade



We did an upgrade from vSphere 4.1 to 5.0

But after it, we have problems with SnapDrive

Unable to map any existing RDM Lun into Windows 2003 R2 SP2 VM

We get the following error message

Failed to create disk in virtual machine, failed to map virtual disk

xxxx.vmdk is greater than the maximum size supported by the database

Datastores (NetApp Luns) have not been upgrade to VMFS5, they are 3.46 version

We don't want to upgrade at this time

SnapDrive version is the last: 6.3.1.R1

Release note speaks only about ESX 4.1 nothing about ESXi5.0

Anybody knows if vSphere 5 is supported by SnapDrive or already encountered this problem ?

Many thanks for your help




Thanks a lot Francesco

We did this test, and it seems better you are right.

if we had enough space, it would be nice to create a new VMFS5 Datastore and vMotion VM

but no more SAN space

And we are a little bit worried to upgrade VMFS (even if it's non disruptive)


I'm not familiar with your configuration but if you work with thick provisioning, temporarily switching to thin provisioning (turning off space reservation of the lun and changing the space guarantee of the volume to none could save you alot of space and enable you to create a new lun for VMFS5. Migrate everything needed to the new datastore and delete/undo the changes for the old datastore. Helped me a lot of times, hope it will be useful for you as well.

Good luck,


We  won't be able to do this,our Luns are too large.

it's boring that snapdrive can not work if VMFS is still old version

What happen in mixed environment, ESXi4 and ESXi5 ,you can not convert datastore to VMFS5

So if VM is on ESXi5 then snapdrive do not work and  it's working if running on ESXi4


an additional information

Before upgrading ESXi 5.0, every thing was ok

VMFS  block size is 1 MB

and RDM Lun size is 30 GB

so under the VMware limit of 256 GB


We had the same problem with 2008 server with RDM luns. We was not able to mount a snapshot of the lun with the same error message.

We had to upgrade to VMFS5 to make it work. For us it worked without problem but before doing it live we "tested" creating a new test lun with a VMFS5 datastore using it to store the RDM configuration while mounting the iscsi snapshot lun.

I've not checked back but I think that 6.3.1R1 is not supported on vSphere 5 (http://communities.netapp.com/message/61868#61868)


NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.