VMware Solutions Discussions

Snapvault integration with cDOT 8.2 and VSC 5.0 GA

mathieu_dewavrin

Hello

I am trying to setup in our lab Snapvault integration between two cDOT Cluster in our lab.

Source cDOT 8.2.1

Destination cDOT 8.2

I created the job in the VSC 5.0 and the snapshot shows the expected snapmirror-label

pdjnetapp::> snap show -vserver vmware -volume pdj_replication -snapshot smvi__Daily_SnapVault_recent -fields snapmirror-label

vserver volume          snapshot                     snapmirror-label

------- --------------- ---------------------------- ----------------

vmware  pdj_replication smvi__Daily_SnapVault_recent VSC_JOB_DAILY

I created a Protection policy including the VSC_JOB_DAILY on the destination cluster

vsim-demolab::> snapmirror policy show -policy VSC_SnapVault_Daily -fields snapmirror-label

vserver          policy              snapmirror-label

---------------- ------------------- ----------------

vmware-nfs-iscsi VSC_SnapVault_Daily VSC_JOB_DAILY

When I configure the protection in order to initialize it in System Manager with the Vault Policy I have a information about Snapshot not matching labels.

When I try to update through VSC or manually through System manager, nothing get transfered to the secondary.

I must be missing a step but I can't see which one and the documentation is not very helpful in that case

Any ideas ?

Thank you

17 REPLIES 17

oweinmann

Did you ever get this to work? I read the manual but it the info on snapvault and vsc 5.x is very small.

No, it looks that everything is setup right but the snapmirror-label isn't correctly seen by the SnapVault Engine

Hmm I have exactly the same issue. I just opened a case with NetApp for this. Let's see what they come up with. I'll keep you updated.

ADVUNIBN1

We have got also issues with non-working snapvaults in VSC 5.

Do you have any updates?

oweinmann

Hi,

just got an email today that support has now raised a bug for this issue. It is very disappointing to see how unstable NetApps newest products are. We also have issues to get SnapManager for Exchange,SQL to update to initiate a Snapvault snapshot. Until now it's not even clear if this is supported under CDot. To me CDOT is an unfinished product as most of the things that used to work great under 7Dot are either no longer working or no longer supported. We strongly consider to move away from NetApp products.

KUBER_KATANA1

"SnapManager for Exchange" -> Did you figure out how to get the SME create snapshots with Label?

Cheers?

I've managed to make it work.

I've used Ontap 8.2.1 as source and Ontap 8.2 as destination

vSphere 6 beta

VSC 5.0.1X3 beta

First, I used the KB to change the default snapmirror-label that VSC puts on its snapshots

https://kb.netapp.com/support/login/p_login.jsp?page=content&id=3014161&locale=en_US

DO NOT use quotation marks in the custom values

I used VSC_HOURLY and VSC_DAILY instead of the standard labels

Setup a Protection Policy using the newly defined snapmirror-labels in System Manager

Still doesn't show the snapmirror labels as existing but I guess System Manager searches for Snapshot schedules and not label.

Initialize the XDP Mirror

Setup a VSC Hourly Backup with SnapVault update

Let it cooked during the night

And voilà, 13 snapshots kept on secondary

Only 4 in primary

Launching a new VSC jobs correctly update the relationship now

Great Stuff,

but my source and dest are 8.2.1 and I have vsphere 5.5 and VSC 5.0 as it is a production system. I can't upgrade to beta versions.

I guess I just have to wait until NetApp is so kind to fix this issue as well as all the other issues with VSC 5.x stable. Like locked AD accounts!

Tried in a vSphere 5.5U1b environment with VSC 5.0GA and it also works with the custom labels.

I had to add the destination Cluster hostname and management IP in the DNS so that VSC could resolve the destination system. Should probably work with entries in the host file of the VSC.

I have VSC 5.0GA I believe. But there was a problem with NetApp NFS in 5.5U1. So I have skipped that. Luckily 5.5U1b fixes that problem. I will have my ESX updated and give it a try. I wonder why it doesn't work with the default labels? I will report if it works. Just struggling with another VMware <-> NetApp issue where SMVI puts VMs to "disk consolidation needed" state after a backup job has run.

I hate beeing a beta tester!

Followed your howto but coudn't get it to work, even with the custom labels.

<< I had to add the destination Cluster hostname and management IP in the DNS so that VSC could resolve the destination system. Should probably work with entries in the host file of the VSC. >>

I guess this could be my problem. I have a DNS record for the destination system that can be resolved from the VSC host. Do you have any clue what ports need to be opened between the VSC host and the destination storage system?

One of the standard port I suppose

From the VSC documentation https://library.netapp.com/ecmdocs/ECMP1392339/html/GUID-4F4DF46E-16A1-4A94-9CB3-7EC2CCDC7716.html

VSC uses the following default ports

443The VMware vCenter Server and the storage systems listen for secure communications using secure HTTP (SSL) on this port.
80The VMware vCenter server and the storage systems listen for standard, unencrypted communication via standard HTTP on this port.
8143VSC listens for secure communication on this port.
8043The VSC backup and restore features and the VSC Restore Agent and CLI listen for secure communication on this port.

Thanks for that. Would be good to know which ports are actually needed from VSC to the filer. VSC and VC are on the same subnet, so there are no blocking firewall rules, but the filer sits on a different subnet with a firewall in between. So far we had http, https and port 623 open. I ran wireshark on the VSC host to see if it tries to communicate with the destination filer as soon as I trigger an ondemand backup job from VSC but there is just nothing...

oweinmann

I have two Vservers VMWARE and VMWAREBAK. Maybe they need a mgmt IP on the same subnet as the VSC?

In my setup the VSC was in another subnet than the MGMT of the clusters

Hi,

NetApp Support had a good idea. I had to add the Snapvault destination filer in VSC. Now it works with the custom labels as well as with the default ones. However OnCommand System Manager still shows that there are no valid snapmirror labels. And another bad thing is that the naming scheme on snapvault destination filer doesn't contain "_recent" for the latest transferred snapshot. This makes it impossible to backup to tape as we can only select one single snapshot with a constant name.

Is your snapvault destination in the same cluster as your source or is it a intercluster setup?

I  can not see the pictures ,can you sent it to me ? mail:xuj@pkit.com.cn ,thank you!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public