VMware Solutions Discussions

Upgraded SRA to an unsupported version.


My environment:


The snapshots travel in one direction - to a warm site.

VMware vSphere 7.0.3k

NetApp Ontap 9.9.1p14

SRM 8.5

SRA.... this is the problem.


According to the compatibility matrixes at VMware and NetApp, I upgraded my SRA's to an unsupported version.  I had been running 9.7.1 and saw that 9.10 was available so I upgraded.  I thought that I had read the charts correctly, but I obviously didn't.


The adapters seem to work and I get green checkmarks everywhere I look, but when looking at the the SRM appliance, under "Array Pairs", one of my NetApp's show that the status for the transfers is "forwarding" (which is correct), and the other NetApp device shows the status as "Unknown". 


All of the other checks are green and snapshots are definitely being replicated on their respective schedules. 


The only error that I can find is this one "unknown" status.  I have not tried to do a restore yet.


In any case, I'd like to get my environment back to a supported state.  I have found that I can unregister my SRM's which will take out my SRM's and SRA's Unregister the Site Recovery Manager Appliance (vmware.com) but I was wondering if I can simply unregister my SRA appliances and build back a supported version?  I know that I can delete my SRA's in the SRM interface and then reregister them, but I tried that and what I ended up with was mish-mash where my adapter version is 9.10 (unsupported) and then it lists the install location as 9.7.1.





Have you reached out to NetApp (raised a ticket for this issue) ? Hopefully someone in this situation before may be able to give you advise in the meantime.


Thank you for the reply.


Unfortunately my company purchased support through a 3rd party.  They are good at Googling answers and sending me links, but not fixing the issue.  They aren't great (at least in my experience).   They have never escalated any of my tickets but have sent me numerous links.


I did open a ticket with them, and they were the ones that let me know that I have versioning issues, but other than recommending uninstalling SRM completely, they have (so far) offered no other advice.


I found the article on unregistering SRM, but can't find anything that pertains strictly to the SRA's.


I don't want to have a bunch of garbage in the database pointing to SRA's that didn't get removed correctly.