VMware Solutions Discussions

VAAI configuration on FAS2040 with ONTAP 8.0.1

VALLEY911

Hi All,

Hoping somebody can shine some light on an issue I am seeing with our FAS2040 and ESXi 5 host with VAAI. Issue being that it appears not to be working. When viewing the storage array through vCenter using the VSC the array shows as "Enabled" for "VAAI Capable". I am presenting two FC LUNS from the array to one of my hosts that I am doing the testing on. I have confirmed that the correct ESXi modules are being loaded (esxcfg-module -l |grep vmw_vaaip_netapp) on the host as well as confirmed that the devices are showing as "Supported" for VAAI (esxcfg-scsidevs -l | egrep "Display Name:|VAAI Status:"). So from this I am thinking I am good. I fire up ESXTOP/RESXTOP and go to the Device screen (u), remove all fields except for DEVICE and VAAISTATS (f). I run a Storage vMotion job of a VM from one LUN to the other expecting to see changes in the counters for CLONE_RD and CLONE_WR but get nothing.

I have read through TR-3886 which covers the VAAI aspect for NetApp and believe everything has been configured correctly. HELP!

Thanks in advance,

-Jason

1 ACCEPTED SOLUTION

rodrigon

Hello Jason,

Is it enable on the hosts? Because it is enabled by default at Data ONTAP 8.0.1 and later.

Nascimento

NetApp - Enjoy it!

View solution in original post

5 REPLIES 5

rodrigon

Hello Jason!

If you are using Data ONTAP 8.x or later, restart your test and during the Storage vMotion connect at your FAS2040 and run this command:

stats show vstorage

At the output you should see some fields as vstorage:vfiler0:xcopy_copy_reqs increments.

I hope it helps!

Nascimento

NetApp - Enjoy it!

VALLEY911

Rodrigo,

Thank you for the post.

I am currently running version 8.0.2 on our array. When running another Storage vMotion and issuing the "stats show vstorage" command I receive the following output:

vstorage:vfiler0:xcopy_copy_reqs:0

vstorage:vfiler0:xcopy_abort_reqs:0

vstorage:vfiler0:xcopy_status_reqs:0

From this I am guessing VAAI is not working correctly.

-Jason

rodrigon

Hello Jason,

Is it enable on the hosts? Because it is enabled by default at Data ONTAP 8.0.1 and later.

Nascimento

NetApp - Enjoy it!

View solution in original post

VALLEY911

Rodrigo,

Indeed it was disabled on the ESX host under advanced properties. Not sure as to why as the other 4 nodes in our cluster are configured correctly. I should have looked there.

Thank you for your assistance.

-Jason

badami

VAAI is enabled on the ESX/ESXi host running 4.1 or later.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1021976

Cheers,

-Apoorv

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public