VMware Solutions Discussions

VSC 6.0 installation

JustinMedcraft

I have installed VSC6.0 onto my Virtual Centre.  It is my intention to use it to manage all SnapVault backups of VMDKS from one site to another.  Since this is version 6.0 I need to use the web interface.  I am also using Clustered OnTAP 8.2.3.  We have one SVM which has four NFS data LIFs.  Each LIF is using a non-routable IP address (i've provided this information since I believe it may be useful).  When I open the VSC console and browse to Storage Systems I can only see two storage systems showing the IP addresses of only two of the LIFs.  Each of these entries also states that TLS is not configured and that I should enable TLS on the storage system OR right-click, select Modify to change.

 

I've attempted to do this but to no avail.  When I right-click to modify and deselect 'Use TLS to connect to this storage system' I receive an error stating that 'The hostname:port# cannot be resolved'.  This to me seems like the VC cannot see the storage network...

 

How do I resolve this?  Any ideas guys?

6 REPLIES 6

morris_nwn

Did you find a resolution for this problem? I'm having the same issue

c_unciuleac

For TLS to take effect on storage systems running Data ONTAP operating in 7-mode, the option “httpd.admin.ssl.enable” must be set to on.

macartm

WE also had this recently, after resorting to reinstalling VSC when our backups stopped working.

 

The root cause, it turned out, was nothing to do with VSC ...

 

We're running vCenter on a windows server. It had recently had a packaged version of IE11 installed. IE11 disabled SSL v2.0 and v3.0 in the IE settings. VSC must be leveraging the same crypto libraries, because it too would refuse to connect to some of our storage systems. Frustratingly, all you get is 'the host:port# is invalid' which did NOT help at all in finding the root cause. What did help was using Wireshark and seeing the SSL handshake was being rejected. By comparing with working systems, we eventually found the answer.

 

To enable TLS, use the command

 

options tls.enable on

 

 

jr126

Did you find a solution to this isssue? I am having the same trouble running Clustered Mode. 

macartm
Well turning on TLS sorted it for me. Get wireshark out and have a look at the traffic if you can.

The error message is not helpful as there are multiple possible causes.

jr126

TLS is enabled. It is on by default in clustered on tap. I did verify also.  I'll take a look with wireshark and see if I can capture what is going on. 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public