VMware Solutions Discussions

VSC backup shuts down SQL service


Hello all! 


I've noticed a few days ago that SQL service on one of our servers had stopped. It's a virtual Server 2003 R2 in vSphere environment. I restarted the SQL Server service, but tomorrow morning I encoutered the same situation. 


Subsequent log analysis through Event Viewer showed me that the first errors are always logged by VMware Tools - precisely 15 minutes after VSC backup job is initiated on that VM (during the night),



































Which is then followed by SQL service stopping:



















































I have tried modifying VMware Tools configuration, by removing it's VSS support module, and running the VSC backup job manually - and it worked, at least the 1st time. But then it went back to the old routine. I don't know if it's worth mentioning, but Snapmanager for SQL is present and it's working fine. 


Any ideas what might be the cause? Or where to start looking for one?





Re: VSC backup shuts down SQL service


I searched some threads and it turns out that there is a know issue with the VSS writer of SnapDrive colliding with the VSS writer of VMware tools. However, this is a very recent event on an old setup. And I did remove the VSS from VMware Tools...


Some additional info:

ESXi 5.1.0 updated, virtual Server 2003 R2, MSSQL Server 2005, VMDK on FC datastore for system parition, RDMs on FC LUNs hold the databases, SMSQL version 6.0.1, SnapDrive version 6.4.2, VSC version 4.2.1.

Re: VSC backup shuts down SQL service


Apparently, the problem wasn't in VSS writers - but VSS providers.


There only needs to be one VSS provider present, it this case that was DataONTAP VSS Hardware Provider. The solution was to stop "Microsoft Software Shadow Copy Provider" service and set it to Manual.



View solution in original post

2021 NetApp Partner Experience Survey
PES Banner
All Community Forums