VMware Solutions Discussions

Virtual storage console alert

imarcroft

I have install virtual storage console into virtual center authenticated with the filer heads.

It has picked up the ESX hosts and I have right clicked on each and selected set recommended values as I normally do.

I have then rebooted each ESX hosts

despite this the MPIO settings have a red Alert next to them. the ESX hosts have 2 FC connections into 2 independant Broc's

I can't find any information what the Alert is

Has anyone else seen this issue???

thanks

14 REPLIES 14

dbkelly

Hello,  We have seen issues like this before.   Please open a case with NGS and upload the vsc.xml and vsc.log file. 

If you want to investigate yourself, look for isMpioSet in the log file. At the end of the line, it should report true or false.    It appears that one of the LUNs is not being set correctly.   I need the logs to see why.

Another way to see what is misconfigured is to right click the host and select 'host details...'   It's tedious, but for each path, review the settings for each LUN.   If the SATP=ALUA, then the PSP should be set to RR.  If the SATP=DEFAULT_AA, then the PSP should be set to fixed and a suitable non-proxy path should be set for the preferred path.

jtham

I am seeing the same problem.

I am able to manually set a preferred path on our ESXi 4.1 host through our newly installed VMware vCenter instance .  What I am not able to do, however, is to use the virtual storage console 2.0 plug-in for VMware vCenter to set the preferred paths.   It looks like the vsc was installed and configured correctly, because I am able to add storage controllers and I can see through the manage plugins window that it is installed.

The problem behavior can be seen here:

As you can see, there is an alert in the MPIO settings, and whenever I try to “set recommended values,” it errors out on the MPIO settings portion.  Also, when I go to the show details command here, it shows many details in green which seem to be correct settings, the only setting in red is the following:

Any ideas on what could be the issue?  I have already opened a ticket with Netapp support but they haven't gotten back to me yet.

dbkelly

The 'mpiosetting' field in the Host Details is value of the icon you see, so I expect that to be false (since you are seeing an alert).  In order to tell which LUNs does not have the correct MPIO settings, you will need to expand and look at each LUN, and all the associate paths.   If you have access to the logs, grep for 'isMpioSet'.  That will narrow down which LUN does not have the correct MPIO Path setting. 

imarcroft

Hi

I don't want to tell you how to "suck eggs"

I take it the hosts in question have been rebooted?

has all the zoning been checked on the switches?

have you checked the igroup settings for the LUN's?

jtham

Yes, I have rebooted all the hosts and double checked the zoning is correct.  Thanks for the suggestions on checking out the LUN settings, I'm going to go through the logs this afternoon and see if I can find something there.

imarcroft

is the igroup ALUA enabled?

check this from system manager

jtham

No, the igroup is set to SATP = default and path = fixed

imarcroft

I beleive the reccommendaion is to have ALUA enabled and the Path settings for the LUN on the ESX servers are changed to ‘Round Robin’

wmccormick

To imarcroft and j-tham.

We are seeing this same problem and have been working with NetApp for several weeks to resolve this with no resolution so far.

Have you resolved the issue?  If so, how?

Thanks!

jtham

Well it turns out that the igroup settings we had (VMware fixed path settings) for some reason do not retain path information on the host.  We tested out enabling ALUA on a different igroup on one of our hosts that is independant from our production vsphere environment, and after doing that, we didn't see the problem anymore.  We are currently in the midst of migrating our entire vSphere 3.5 environment to vSphere 4.1, after which we will enable ALUA for the entire production igroup and should not see this behavior anymore, but I can update you when that is done to confirm this is a fix.  It wasn't explained to me by support why ALUA is necessary and/or why VMware fixed pathing isn't persistent, but at least it's working.

jerome_barrelet

I confirm as well that enabling ALUA solve this error, and if you have the VSC plugin 2.0.1 it will  change automatically the datastore connection to to round robin instead of fixed path.

Jerome

Hi, we are having the same problem with the permanent Alert in VSC for the MPIO settings.

Checked that all luns are set with RR, however all storage array types are VMW_SATP_DEFAULT_AA.

In the NetApp System Manager, we can't set ALUA for iSCSI initiator groups - it is greyed out.

Hi,

That's normal ALUA is not supported for iSCSI configuration , only for FCP. You have to find something else to solve your issue .

ok, so I ran the update in the VSC, now the alert is gone!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public