VMware Solutions Discussions

When I run mbrscan get [permission denied] for some vmdk's


I am running ./mbrscan --all some of my vmdk files come back [permission denied].  This is just recent I have been slowly aligning all of my disks as I have had some performance problems but last night I saw this error.  I have seen the [Device or resource busy] error and that makes sense because those vm's are on but the [permission denied] thing does not.  it does not seem to make a difference whether the vm is on or off.  I even tried moving one to a defferent data store just to see if that resolved it but it did not.  It is not all of my vm's that have this only some and it seems random some work.  If anyone can let me know what is happening that would be great.  THanks in advance.



Hi Wally,

     Are these NFS or VMFS datastores?  Are you logging into the service console with the root account?  The most likely case is that something has a lock on the vmdk file (a vm that is powered on references the vmdk file).  If you are using NFS and happen to have taken a snapshot, you can always scan the vmdk files in the .snapshot directory.  You should also be able to take a VM level snapshot, perform the scan, then release the VM snapshot.

Hope this helps,