VMware Solutions Discussions

how to activate default thin provisionning in a netapp NFS Volume



I am using a netapp FAS 2040 with nfs volumes for vmware datastores

I do not want to use thin provisionning in vmware but with NFS the option is forced to thin

could someone tell me where I can validate to force thick provisionning from the fas 2040?

the volumes are flexvol with the guarantee parameter to volume





If  the objective is to fully provision a VM stored in an NFS database, it can be thick provisioned by performing either of the following options:

  • From ESX/vCenter:
  1. In ESX/vCenter, browse the datastore where the virtual machine’s virtual disk (.vmdk) is stored.
  2. Right-click the disk and select Inflate.
  • From the Filer:

Run the following command:

file reservation /vol/nfsdatastore/virtual_machine_name.vmdk

Hope this helps..



hello thanks for your answer I knew the inflate option but wonder if there is a way to validate it by default

I am interrested of your point of reservation for the filer

after having inflated the vmdk vmware indicates 125 GB used and the filer indicates 125GB used too

so why is this file reservation necessary?

do you have more clues on this option?

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner