VMware Solutions Discussions

SMVI failing to back up VMs - "Another task is already in progress"

paulreed

Just installed VSC 2.1.1 and have set up a job to run very hour. Of the 6 VMs that reside on the datastore I am trying to backup using the SMVI functionality, only 2 complete. The other 4 servers all fail with the same error:

VMware Task "CreateSnapshot_Task" for entity "<server name>" failed with the following error: Another task is already in progress.

I can rule out any issues with the VMware Management Services as I can manually snapshot each VM. However, this process doesn't quiesce the VM so I followed this articles instructions and all seem fine:

http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1007696

I have tried to log a call with NetApp Support who simply said:

You will have to get a case opened with VMware to get the logs and see what is causing that to fail.  It looks like a VMware error message.

Pretty poor response as far as I'm concerned. I could call VMware, but I expect they would say that as all other VMware functionailty seems fine it is an issue with SMVI. I think I'd agree with that too.

Another, less pressing issue, is the format of of the log entries in the email notifcation - it's in IPv6 format. I've since disabaled IPv6 on the vCenter server but it doesn't change. Quite annoying

https://[fe80:0:0:0:0:100:7f:fffe%10]:8043/smvi/logViewer?id=backup_SMVI_20111121110001


2 REPLIES 2

Re: SMVI failing to back up VMs - "Another task is already in progress"

paulreed

Update:

Just followed these instructions from VMware to reregister the VMware Snapshot Provider. No change

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1019848

Re: SMVI failing to back up VMs - "Another task is already in progress"

paulreed

Think I may have resovled the issue. There is a legacy installation of Symantec BESR on many but not all of the severs. Removing that on one of them fixed the problem.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public