VMware Solutions Discussions

mbralign error


I am getting this error using mbralign and I was wondering if anyone else has seen it, two level 1 tech support people at NetApp say they don't know what it means or how to fix it and I've been waiting all day now for an answer back from them.  It has given this same exact error on four vmdk files of four different virtual  machines that are in three different LUNS on three different volumes.  There is a ton of free space in each LUN compared to the sizes of the vmdk files.  This is my first time trying to run mbralign (at the guidance of NetApp support for an open case I have) so I have never seen it work on my system.

Are you sure that no snapshots/linked clones exist for this vmdk? (y/n)y
Creating a backup of acbk02.vmdk
Creating a backup of ./acbk02-flat.vmdk
Creating a copy the Master Boot Record
Working on partition P1 (3): Starting to migrate blocks from 32256 to 32768.
IO error write OUT.2: full write failed,  was written out of 8192
Shall I restore acbk02.vmdk from the backup I made?



I solved it after being on the phone with NetApp 2nd level support (they are great compared to the so so experiences I've had with 1st level support by the way) and having a second putty session open to the filer while mbralign fired off on the ESX box, we noticed the filer spitting out a message about a new iSCSI connection from the IP address of the ESX box that mbralign was running on.  We weren't sure what to do with it at the time and he was going to turn it over to one of their vmware specialists but before I got a call back I reconfigged the HP switch port the ESX box was attached to (this ESX box was not a production machine, I just threw it in to be able to run mbralign since my production heads are ESXi) and that solved it.  It was a network error all along causing the isSCSI to crap out and making mbralign report the error that basically means there isn't enough disk space.