VMware Solutions Discussions

mbralign tool

aaw

From the instructions I can see this tool is only available to ESX Hosts not ESXi Hosts.

Any ideas if this tool will be available for ESXi Hosts?

Thanks
Carol Ostos

9 REPLIES 9

jerimiah303

I use a linux vm to run mbralign on NFS datastores for ESXi. Basically, setup a linux vm, allow access to the datastore and run the utility.

One advantage of running on a linux vm is higher throughput as ESX limits the console.

forgette

Although not technically supported, Jerimiah's suggestion has been reported to work quite well on NFS datastores (for the reason he describes).

TIP: The --sparse option should be used on NFS datastores to increase speed and save space.  This results in think vmdk files.

forgette

Sorry, this tool is not available for ESXi.

cplock

We use nfs, and use netapps mbralign tool from a linux non-ESX host. You could even use a VM that mounts the same storage, to align vmdk files (while vms are off), but latest mbralign doesn't work. The one we have that works is mbralign version 1.40090416.  the newly released toolkit 2.0 has a new mbralign and no mbrscan.  the new mbralign doesn't have a version number and works to check vmdk files (via --scan flag), but when attempting to align it throws an error about 'cannot find mbralign.pl at line 1667'.  It appears broken.

forgette

Cross posting http://communities.netapp.com/message/37760#37760

Hello.  I'm sorry to report you've stepped on a bug in 5.2.  The following Knowledge Base article should help: kb59502

The work around at this point is to download the ESX Host Utilities Kit 5.1 and extract the mbralign utility from it.

cplock

Yes, I double checked, thats exactly the one - the version we have thats working (mbralign version 1.40090416) is the one provided in the ESX Host Utilities 5.1 - link helps since its slightly obfuscated in the download center which offers it only as Utilities for FC or iSCSi  (not NFS):   http://now.netapp.com/NOW/download/software/kit_iscsi/esx/5.1/download.shtml

Since the ESX Host Utilities 5.2 has a new version of mbralign that doesn't work for me, will there be a 5.3 release or a way to get the newer tool that works?  Thanks!

bsti

This post is quite old, and from what I can see this is still an issue.  I tried the mbralign tool from VSC 2.1.1 (most recent version as of this date) on a .vmdk on ESX 4.1 and it was unable to realign it.  It did the scan the whole datastore thing.

I did download the 5.1 version and it worked like a charm (no corruption), but I still can perform scans using version 5.2. 

I've not been able to locate a new, fixed version of mbralign.  Does anyone know of one out there?

rodrigon

With VSC 2.1, a new suite of mbrtools is available, in this new version you can find mbrtools for ESX and mbrtools for ESXi.

Nascimento

NetApp - Enjoy it!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public