VMware Solutions Discussions

vCenter 5.5 - VSC 4.2.1 - Failed to determine privileges for operation



I'm running vCenter 5.5. with VSC 4.2.1, and I face the same problems as many others, "Failed to determine privileges for operation:Edit" when trying to edit my backup-jobs.

Any clues on how to fix this? I've seen there are several threads on this, but no answer in any of them.





I hit the same issue today after updating VSC4.2.1 on a VMware 5.1 environment.

One out of two backup jobs have this issue.

I can create a new job with the same setting but I can't delete or suspend the backup job with this issue.

The only thing i can think of is that I deleted some datastored who are linked to this job.



I had the same issue, but after remounting the removed datastores with the original names I was able to edit the backup again.

Hi everyone,

I have the same issue, but I can not remount the removed datastore, because we've deleted it from the storage system.

I think a recreation of the datastore (create a new one with the same name) won't work, because the new datastore would have a new UUID which will be different from the previous one.

Is there a way to delete the obosolete backup job without remounting the datastore?

Thanks in advance.

Hi again,

solved the problem by

1.) Stopping the service "NetApp SnapManager for Virtual Infrastructure",

2.) Editing the file   %ProgramFiles%\NetApp\Virtual Storage Console\smvi\server\repository\scheduledBackups.xml    by removing the xml-parts of the backup-job which is making problems.

3.) Starting service "NetApp SnapManager for Virtual Infrastructure".

Thats it.

This solution worked for me. I confirmed it with NetApp Support. Thanks for the tip, .


-Robert Salcido


worked for me too, thanks for the tip!


why is there no official netapp KB addressing this issue?

if one needs to work with this plugin (which has been around for a while...) one needs some kind of control over it.

why cant i see the schedule backup jobs from the web client? why no edit options?

at least release a kb explaning how to properly manage the vsc backups....



Can you check your logs and confirm if you see anything there  ?

\\NetApp\Virtual Storage Console\log\smvi.log

\\NetApp\Virtual Storage Console\smvi\server\log\server.log

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner