VMware Solutions Discussions


vVol creation error for .vSphere-HA protected folder



is anybody else facing with error when starting up a VM on the vVol datastore? I have an error failing to create .vSphere-HA folder for HA protected machine list.

From VASA provider log the message as follows:

Caused by: com.netapp.offtap3.ontap.ApiFailedException: Invalid VM name: _vSphere_HA. VM names must be between 1 and 254 characters in length. The first letter must be one of A-Z or a-z. The remaining characters must be A-Z, a-z, 0-9, space or valid ASCII punctuation. (errno=13001)

Does anybody knows how to solve that, or is there a "secret" patch for this issue?

The .vSphere-HA folder is created automatically by vSphere and it is not the VM!


AFF A300 (9.4P5), VSC 7.2.1P1


Thanks for response 


Re: vVol creation error for .vSphere-HA protected folder



I am sorry you are seeing this problem.  I suggest you open a Support case on this.



Re: vVol creation error for .vSphere-HA protected folder

Any news about this issue? I have found, that there is KB article from June with linking to Bug 1212933, but I have been creating SR in March and till that time NetApp was not able to solve this issue?? How long it will take?

Re: vVol creation error for .vSphere-HA protected folder

Hi George,


We have identified changes in ONTAP and the virtual appliance (VASA Provider) to address this.  The ONTAP changes are targeted to 9.6P1 and 9.5P8.  The virtual appliance changes are in the 9.6 release, targeted for August release.  Both are undergoing QA testing, so these may change.  I hope this helps.



Re: vVol creation error for .vSphere-HA protected folder

I have updated to the latest NetApp release of 9.5, which is 9.5P7 (August) and it doesn't solve the problem. Do you have any info about the 9.5P8 release date, which you have mentioned previously?


In the release notes of 9.6P1 or 9.6P2 isn't also any info about this problem to be solved. And in the release bug report is nothing about releases, that should solve this issue.


Re: vVol creation error for .vSphere-HA protected folder

So Ontap update 9.5P8 was released on 1st October, it looks, that it should solve this issue, because it is mentioned in the Bug list. But only for 9.5 branch, not for the 9.6 branch.

Re: vVol creation error for .vSphere-HA protected folder

I tried 9.6P3 and as you guessed, it has not been fixed there yet.  I then downgraded my test environment to 9.5P8.


It does look like 9.5P8 improves the .vSphere-HA behavior when you enable HA.  I've created both NFS and iSCSI-based vVols and I'm now cloning some VMs to them with HA enabled.  For the iSCSI vVols I was able to see .vmdk files appear in OnCommand's LUNs pane as expected.  I am getting an "Object type storage alarm" in the Datastores navigation pane, but that could be due to Protocol Endpoint issues with my test environment and/or the downgrade.

Re: vVol creation error for .vSphere-HA protected folder

I have seen vCenter raise object type storage alarms, and sometimes they go away.  In one case I restarted vvold on a host and that cleared it.  In two cases I think it was related to PE LUNs.