Ask The Experts

XCP not transferring domains ACL

Mohamed_Magdy_Said

I am using XCP to migrate data from EMC  to new Netapp.   BUT  Domain ACL's not trasferring to target.

4 REPLIES 4

Trubida

Does the user that you are running the job with have the correct permissions to those files/folders?

mic_cologne

I'm suffering the same effect, "xcp copy" with or without "-acl" (and the fallback senario) has exactly the same result: everyone -> full control, at any file at target. 
The user im starting the xcp command is member of the lokal "Backup Operators"-Group; so every file - even confidential ones - are copied, whitch is good, but no ACL information is transferred, wich is quite anoying...
Does ANYBODY know the clue??

mic_cologne

bad news from developers:

"XCP SMB 1.1.1D1 or older versions do not copy root ACLS because it was the attribution of the migration team to set them at root level and the Windows system to propagate them. 

XCP SMB copies only ACLs that are N-1 level below root directory, but only local ones. The inherited ones are propagated by Windows depending of the Inherited and Propagation flags of each ACE in ACL.

Root level copy support for XCP SMB going to come in next release."

so, for me, this tool ist totaly useless...

JoanWu

Tried to migrate from Hitachi HDS 150 to FAS3270 DoT 8.1.4 7-mode with XCP ver 1.5 running on Windows 2012.  Both sides were CIFS shares in the same AD and were mounted on the same Windows VM with XCP running on it by domain administrator.  XCP copy cmd was used. File transfer worked as expected but only EVERYONE permission was seen at destination FAS end, which is different from the permission of source files and folders.

 

Is there any update on Windows ACL transfer of XCP VERSION 1.5?   

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public