ONTAP Discussions

FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

Hello,

I have 3 different independent clusters that are all running 8.3.2 and I want to upgrade them into the 9.x stream. 

 

1 x 8040 validates successfully. Need to get this up to 9.7

1 x 2240-2 validates successfully. Need to get this to 9.1

 

My other 8040 cluster is showing this error:

 

CLI output:

cluster image validate -version 9.0P4

It can take several minutes to complete validation...

Error: show failed: Both primary and backup images should be available for validation. One or both of them are not available

 

WebUI:

 

Failed to retrieve the validation information.

Reason: Validation failed because the software image selected for the validation is unavailable.

Click Retry to revalidate the cluster.

 

The only change that has occurred with this cluster is I have recently unjoined both a FAS3240 and FAS3250 from it. 

Any idea on why this error is presenting itself? 

5 REPLIES 5

Re: FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

what's the output of  "cluster image package show"

 

Also, why 9.0P4?  why not 9.1P latest? 

Re: FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

cluster image package show
Package Version Package Build Time
---------------- ------------------
8.3.2P12 8/13/2017 20:57:01
9.0P4 6/17/2017 12:58:01
2 entries were displayed.

 

I don't have any issues moving to the latest 9.1, however it doesn't matter what version I upload to the 8040 will not validate. 

 

cluster image package show
Package Version Package Build Time
---------------- ------------------
8.3.2P12 8/13/2017 20:57:01
9.0P4 6/17/2017 12:58:01
9.1P20 10/28/2019 08:37:28
3 entries were displayed.

 

cluster image validate -version 9.1P20

It can take several minutes to complete validation...

Error: show failed: Both primary and backup images should be available for validation. One or both of them are not available

 

 

 

 

Re: FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

Got ya.   just wanted to check that. 

 

how about... "set adv; system node image show -instance " 

Re: FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

Found out there was still an old node still in the DB.

 

Ran debug smdb table cluster_package_ownership_rdb show

 

node                                 role

------------------------------------ ---------

8153030e-4c2e-11e5-9d9c-85ebde5ee891 secondary

 

Deleted this GUID and the image can now be validated. 

 

https://www.randomlyexpressed.com/cluster-image-package-command-fails/

View solution in original post

Re: FAS 8040 Upgrade to 9.0 or 9.0P4 Validation Failure

set d; debug vreport show  is another good one to run after you remove nodes. 

Review Banner
All Community Forums
Public