ONTAP Discussions

FAS2020 and multiple VLANS on VIF - one VLAN not responding

DerwentGuy

I was hoping someone could help me with a networking issue I have had with a single  NetApp FAS2020 running Data ONTAP 7.3.6 and a Cisco 2960S running IOS 12.2(55)
The filer was originally configured as shown below:

 

vif create lacp vswif1 -b rr e0a e0b
ifconfig vswif1 172.16.80.92 netmask 255.255.255.0 mtusize 1500 mediatype auto
ifconfig vswif1 alias 172.16.80.91 netmask 255.255.255.0

 

I stopped all the interfaces and entered the following commands

 

vlan create vswif1 1 2 3 4
ifconfig vswif1-1 172.16.80.92 netmask 255.255.255.0 mtusize 1500
ifconfig vswif1-2 172.16.81.92 netmask 255.255.255.0 mtusize 1500
ifconfig vswif1-3 172.16.82.92 netmask 255.255.255.0 mtusize 1500
ifconfig vswif1-4 172.16.83.92 netmask 255.255.255.0 mtusize 1500

 

I then reconfigured my Cisco switch with the following commands from the config prompt


interface Po 4
switchport mode trunk
switchport trunk allowed vlan 1-4
switchport trunk encapsulation dot1q
switchport nonegotiate
spanning-tree guard loop
spanning-tree portfast trunk

 

I then configured two ports as follows to create the etherchannel

 

switchport mode trunk
switchport trunk allowed vlan 1-4
switchport trunk encapsulation dot1q
switchport nonegotiate
spanning-tree guard loop
spanning-tree portfast trunk
channel-protocol lacp
channel-group 4 mode active

 

Everything came up and I then tested pinging the netapp interfaces on all four vlans. Vlans 2, 3 and 4 responded OK but vlan 1 interface did not respond which is the address my VMWare hosts look for. These are the only vlans defined on the switch. The filers default route is to the VLAN 1 svi address on the switch. The routing table on the switch has the following entries:


172.16.0.0/24 is subnetted, 4 subnets
C 172.16.80.0 is directly connected, Vlan1
C 172.16.81.0 is directly connected, Vlan2
C 172.16.82.0 is directly connected, Vlan3
C 172.16.83.0 is directly connected, Vlan4
S* 0.0.0.0/0 [1/0] via 172.16.80.1

 

Have I missed something out of the switch setup or the filer setup that is stopping the switch seeing the filer on vlan 1?

Any help will be appreciated 

2 REPLIES 2

axsys

can you please add the output of route -s on the filer? are you able to ping the default gateway (according to your info should most likely be 172.16.80.1?)

as well ifconfig -a or just for the interfaces, as you wish.

 

cheers

shatfield

You've told the netapp to expect VLAN 1 to come in tagged.  You'll need to tell the Switch to send it tagged by setting some other VLAN (even a dummy vlan) as the native vlan on the port channel.

 

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public