ONTAP Discussions

NFS access from a cifs share folder


Hi Pals,


We are trying to provide an SFTP access to linux servers from CIFS share folder. We are able to mount it with root user in linux after adding in Netapp Exports. When they are trying to change the owner of that path with local user , it is denied with permission error  .


I have tried changing the following Fsecurity to everyone, options cifs.ntfs_ignore_security =on , user mapping . But nothing worked.


Since it is the first time we are doing , the problem should be at the basics.







you have to map the unix user to the windows user.


It's been done on the fileserver: /etc/usermap.cfg

And tell the filer the UID and GID: /etc/passwd


I suggest to create the volume with security style ntfs and mount it on the Linux host using mount -t cifs


If you go for mixed security, a chown on the linux side kills the windows permissions.



Register for Insight 2021 Digital

INSIGHT 2021 Digital: Meet the Specialists 2

On October 20-22, gear up for a fully digital, totally immersive virtual experience with a downright legendary lineup of world-renowned specialists. Tune in for visionary conversations, solution deep dives, technical sessions and more.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner