Simulator Discussions

Installing & Maximising the NetApp ONTAP 8.1 Simulator


I've written a blog post on how to install and configure the simulator and extend it to use 4 x shelves with 4GB disks giving a total available space of 180 GB.

Let me know how you get on and I'd appreciate any comments.




I used to have a few sims on 7.x running, and within the sims you could setup an HA cluster pair by running the ./ and choosing yes to install the clustered pair.

I downloaded the ESX version of 8.1.1 7-mode and installed it, all good.. though you can't break out to run the or alt+f2 to another tty session to start an install to run an HA pair in one sim.. is this something that is not enabled on 8.1.1 7 mode images anymore or is there a way of doing it?

I can run another vm simulator but its not an HA pair, thats two single controller nodes basically.

thanks, appreciate any feedback.. hard to find a decent how to guide for 7-mode at least on the HA cluster setup.

Before any smart comments come back, i'm talking about an HA pair on 8.1.1 7-mode in the same simulator session. NOT cluster mode I understand cluster mode is v different.



You cannot setup an HA pair with any of the 7-mode 8.x.x ONTAP simulator releases unfortunately. I hope in the future they add this as it would be nice to test it out especially while taking an NCDA prep course.




still not possible to run 8.x Ontap 7 Mode HA Clustered Pair on simulators? For 7.3 it is possible? If so please can someone provide how to?


Posted on your site a big "thanks".

Logging into the SIM I'm getting "Servlets not enabled" and looking at the console I see "Enclosure services has detected an error in access to shelves on channel v1".  Same for all 4 channels.  I tried to be careful following your instructions but I may have missed a step. 



Well, never mind.  I guess access to the filer's is not available via a browser anymore.  You have to use a program called NetApp OnCommand System Manager instead.  I'll have to research the "Enclosure services has detected an error in access to shelves on channel v1".


Yes, with 8.1 FilerView is no longer usable, you need to use OnCommand system Manager. As for the access to shelf error, this shouldn't be a problem and can be ignored, it is erroring as the simulator is trying to replicate features of a physical filer that aren't present.


Have you noticed any performance issues with SIM 8.1?  8.01 performed much better.  8.1 is very slow.  Having issues deploying templates to the NFS datastore on SIM 8.1 running as a VM on esx5.  Within the SIM I've turned off flow control, turned off updating time stamps on the NFS file updates.  SIM has 2 vCPU's and 2GB RAM.  My storage unit is a Nexentastor server with iSCSI and NFS datastores.  Deploying templates to datastores on the Nexentastor screams for a home lab.  I can deploy a w2k3 template 20 GB disk with 8 GB of use-able data  in about 3.5 minutes.  Deploying a template to a NFS datastore on the SIM 8.1 eventually times out?  Right now I'm stuck trying to build a SRM deployment.  Also I turned on jumbo frames withing the SIM and can ping at jumbo frame sizes 8872. My SIM has two nics, 1 mgt, 1 for NFS datastore on it's own vlan.

Thanks for any help!



Will your outstanding write-up mentioned in the start of this thread work with SIM 8.01? 

HAD two SIM's 8.1 running fine, using snapmirror to replicate and was running SRM5 test plans until this morning.  I'm now experiencing the kernel panic and reboot issues I see in other threads.

Oh, by the way if I leave the SIM 8.1 running on workstation instead of moving it to esx5 after changing the disk size the speed issue mentioned above goes away.  The same template can be deployed to the SIM 8.1 on workstation in 11 minutes.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner