Simulator Discussions

Highlighted

NetApp Simulator Version 8 in Hyper-V

Is there any way to get this in .VHD format?  I tried using WinImage 8.1 to convert the .vmdk's to .vhd's and am getting an, "Invalid Slice, No /Boot/Loader" error when I bring this up in Hyper-V.

 

Thanks for any information you may provide.

10 REPLIES 10
Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Hi,

A number of people have tried porting the DOT8 simulator to Hyper-V without success. The key as we've recently realized is that the virtual hardware Hyper-V presents to Data ONTAP is different than what is presented by VMware. The DOT8 simulator doesn't currently have drivers for the Hyper-V virtualized hardware, so even if you translate the VMDK's to VHD's you'll run into a lack of drivers for basic hardware that will prevent you from booting successfully. I can't say if your error message is due to that or a disk translation issue. As far as I know, the ETA for Hyper-V support in the DOT8 simulator is over a year away. Right now your best bet would be to use one of the VMware products. Player is free and can run the DOT8 simulator well.

Take care and hope that helps,

Miroslav

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Hello, Miroslav.

Was anything changed with support of Hyper-V by your DOT-simulator? Or it is still unable to run it on Hyper-V?

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Cant Install VMware if Hypervisor is enabled on Win8. all my VM's is on Hyper V. Any update for HyperV Sim Release?

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

IT's the same situation for me.

 

I Can't the install Vmware Workstation bevcause Hyper-V already installed.

 

I Used ConvertTo-MvmcVirtualHardDisk and create an virtual machine in Hyper-V, but i received the next message in the boot:

 

bootarg.init.low_mem set. This will set the FreeBSD size to 512MB.

NetApp Data ONTAP 8.2.1 7-Mode

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Sorry,

 

I do not introduced myself.

 

I am a new member in the forum. My Name is Moises, Brazilian and i startup working with NetApp System.

 

NetApp is the my new diversion... rsrsrs

 

I Work in the You.I.T, is a integrator and reseller products of NetAPP.

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

I can't believe people have been asking for this for 4 or 5 years, but there still is no support for Hyper-V.

 

COME ON PEOPLE!

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Same suituation here ... expecting a remake/release of a MS hyper-v compatible DOT8 simulator from NetApp.

 

This is seriously taking way too long ...

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Hi, I am new to here.

 

It is true that you can't install Vmware hypervisor on Windows 8 with HyperV. To have VMware hypervisor, you need to remove the HyperV feature from Windows 8 and then reboot. I have success with that, I hope this help users out there. The VMware hypervisor I use is VMware workstation 11.

 

Lan

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Perhaps this will be a useful data point:

I have seen hangs at this exact point when running older "q" images of ontap in the simulator.  This is the point where the loader passes execution to the kernel.  As it turns out, older (8.0 era) optimized kernels were missing the drivers required to run the vidconsole (among other things).   So console output fails back to the comconsole on serial0.

 

Whatever errors the sim is throwing here are probably landing on the comconsole.  If anyone is still trying to get it running on hyper-v, you might try booting with a comconsole configured to see if any additional information is presented.  The next likely sticking point would be NIC drivers, followed by more subtle things like timing accuracy within the guest.

 

 

 

 

 

Highlighted

Re: NetApp Simulator Version 8 in Hyper-V

Curiosity got the better of me.

 

After the last message on the vidconsole, the panic message is written to the comconsole.

The panic happens just after PCI device detection begins.  On a supported virtual platform, you would see a long string of device detections at this point, including the IDE controller and the network cards.  So it appears that Hyper-V isn't presenting virtual devices the vsim can work with.  I was not expecting the network cards to work, but without even an IDE controller it will never make it to the boot menu.  

 

Heres an unmuted capture:

VLOADER> boot
x86_64/freebsd/image1/kernel data=0x921710+0x3db888 syms=[0x8+0x45300+0x8+0x2e834]
x86_64/freebsd/image1/platform.ko size 0x2b0a48 at 0xe71000
GDB: debug ports: uart
GDB: current port: uart
KDB: debugger backends: ddb gdb
KDB: current backend: gdb
get_freebsd_maxmem:  778240
bootarg.init.low_mem set. This will set the FreeBSD size to 512MB
calling find_physmem_partition for 570425344
find_physmem_partition[0]: total_size = 1048576, seg_size = 1048576, map[i+1] = 638976, map[i] = 0 shift 20
find_physmem_partition[2]: total_size = 2147483648, seg_size = 2146435072, map[i+1] = 2147418112, map[i] = 1048576 shift 20
Total physical memory 2097088K, FreeBSD physical memory 557056K
Init phys memory segments
BSD     0: 0x0000001000 ... 0x000009c000 = 634880d
BSD     2: 0x00019a6000 ... 0x0020000000 = 509976576d
VNVRAM  4: 0x0020000000 ... 0x0022000000 = 33554432d
OnTap   6: 0x0022000000 ... 0x007fff0000 = 1576992768d
BSD Maxmem (512 MB) ... 0x27f - 0x20000000
BSD Physical Memory (486 MB)
SK  Physical Memory (1503 MB)
NetApp Data ONTAP 8.2.3 7-Mode
platform module loaded
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM) i7-3615QM CPU @ 2.30GHz (2295.18-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x20651  Family = 6  Model = 25  Stepping = 1
  Features=0x1f8bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,SS,HTT>
  Features2=0x82982203<SSE3,PCLMULQDQ,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AESNI,<b31>>
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant
usable memory = 510611456 (486 MB)
real memory  = 536870912 (512 MB)
avail memory = 490725376 (467 MB)
MPTable: <MICROSFT HYPERV      >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 0
ioapic0: Assuming intbase of 0
ioapic0 <Version 1.1> irqs 0-23 on motherboard
ichpwr module loaded
vsensor: <vsensor>
jaspfor_ident
DBG: [nvmem3.c:83, nvmem3_identify] Identify
DBG: [nvmem4.c:97, nvmem4_identify] Identify
smbios0: <System Management BIOS> at iomem 0xf57d0-0xf57ee,0xf8ec0-0xfd1cd on motherboard
SMBIOS: WARNING: Type 1 structure: SKU Number field has invalid index 77.
SMBIOS: WARNING: Type 1 structure: Family field has invalid index 105.
SMBIOS: WARNING: Type 2 structure: Asset Tag field has invalid index 77.
SMBIOS: Failed to create hw.smbios.t1_partno.
SMBIOS: Failed to create hw.smbios.t2_tag.
pcib0: <MPTable Host-PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0


Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address   = 0x62
fault code              = supervisor read data, page not present
instruction pointer     = 0x20:0xffffffff80522ee0
stack pointer           = 0x28:0xffffffff811275a0
frame pointer           = 0x28:0xffffffff811275d0
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 0 (swapper)
trap number             = 12
PANIC  : page fault (supervisor read, page not present) on VA 0x62 cs:rip = 0x20:0xffffffff80522ee0 rflags = 0x10246
version: 8.2.3: Thu Jan 15 21:30:45 PST 2015
conf   : x86_64
cpuid = 0
Uptime: 1s

The operating system has halted.
Please press any key to reboot.

 

Check out the KB!
Knowledge Base
All Community Forums