Simulator Discussions

Re: Simulate ONTAP 8.1.1 withVirtualBox

Hi Dean -

I just checked the simulator downloads. I used the 8.1.1 download from

some time ago. That download no longer appears to be present. So, the

actual mappings of VMDK's to IDE interfaces may now be different.

I suggest you exmaine the ".vmx" file, which is the machine definition file

for the VM Player software. Look for which vmdk files are

mapped to which IDE interfaces - that will tell you for the specific

release what would need to be setup in VirtualBox.

Bob

Bob Greenwald

Enterprise Storage | HSBC Technology & Services N.A.

26525 N. Riverwoods Dr, Mettawa, IL

T +1.847.739.9524

From: POWELLDEAN <xdl-communities@communities.netapp.com>

To: Robert C Greenwald/HBUS/HSBC@HSBC02

Date: 02/12/2013 12:47 PM

Subject: - Re: Simulate ONTAP 8.1.1 withVirtualBox

NetApp Online Community

Re: Simulate ONTAP 8.1.1 withVirtualBox

created by POWELLDEAN in Simulator - View the full discussion

Sorry, but I've downloaded several different 8.x versions of the

simulator, and I can only see the following vmdk files:

DataONTAP.vmdk

DataONTAP-cf.vmdk

DataONTAP-cf-flat.vmdk

DataONTAP-s001 (through -s024).vmdk

I simply have never seen DataONTAP-var.vmdk, -sim.vmdk or -nvram.vmdk. Am

I missing something?

If I try and load Any file other than dataONTAP.vmdk I get the same error

message as shown above in yard's original response.

Most frustrating -- what am I missing here?

Reply to this message by replying to this email -or- go to the message on

NetApp Community

Start a new discussion in Simulator by email or at NetApp Community

******************************************************************

This message originated from the Internet. Its originator may or

may not be who they claim to be and the information contained in

the message and any attachments may or may not be accurate.

Re: Simulate ONTAP 8.1.1 withVirtualBox

Update on my very recent experience with setting up VSIM under VirtualBox. My simulator is homebult, from latest sources, can not point to the 'download' or image here, but reckon this can be applied in general:

1. Original Instructions from this thread should be followed to the letter (ethernet interfaces, disks and their order - while looking at the .) including the:

2. Setting up the floppy drive AND adding the empty floppy. This will ensure the simulator bootloader have its' disks enumerated correctly, even if it makes no use of the floppy whatsoever

3. If your simulator decides to wake up in serial console mode (mine did), this is what I did to get it back to proper console:

- Set up the serial pipe file (I did it all on Win7,x64)

- Consult VirtualBox help, Serial Port section and download the serial pipe proxy utility

- Connect to it using puTTY

- Somehow (I forgot how, under puTTy) get into VLOADER> (that is the 2nd or 3rd bootloader, just before the kernel is loaded) and

- >setenv console vidconsole

4. This will bring you back into VSIM, menus and all, under virtualbox console

5. From that point on, it just 'works' (so far)

Re: Simulate ONTAP 8.1.1 withVirtualBox

Dean,

I just managed to get my cDOT 8.1.2 sim working on Virtualbox 4.2.10.

I first tried to use the VMWare ovftool 3.0 to convert the dataONTAP.vmx converted into an OVF format. Conversion works, but the import not.

When importing, the disk images seem corrupt, or keep complaining that

So I've used Bob's step by step plan (the first posting in this thread), combined my previous experience to convert/import version 8.0 into Virtualbox.

1. I downloaded the player/workstation version of the sim_8.1.2, and unzipped it into a folder.

2. I started the creation of a new VM, cDOT, FreBSD (64bit) with 1600MB and 2 CPUs

3. Do not create a hard disk,

4. but point to the existing vmdk disks:

DataONTAP.vmdk  > connected to IDE primary master > normal, 1.03 GB

DataONTAP-var.vmdk   > connected to IDE primary slave > normal, 1,51 GB

DataONTAP-nvram.vmdk > connected to IDE secundary master > normal 5,00 GB  

DataONTAP-sim.vmdk  (this is the disk that is split up into several parts, but you'll find a DataONTAP-sim.vmdk beneath all these S001 to S0xx.vmdks) > connected to IDE sec slave > normal, 250 GB)

5. it is crucial to add the floppy controller, AND add the empty floppy device 0, otherwise, the system will not find the correct boot device(s). And remove the cdrom device.

As of step 6, I followed all steps Bob used, and my vsim booted without problems.

I'm now able to use OC System Manager 2.x from within another W2K8 Virtual Machine and my Lenovo host laptop to configure it further.

I have not yet tried cDOT with 2 sims yet. To be continued !

Good luck !

Johan

Re: Simulate ONTAP 8.1.1 withVirtualBox

Guys,

I'm using Clustered ONTAP 8.2 in my VirtualBox right now.

I just had a couple of problems to join a second node to the cluster. After looking for network problems I found that VSIM discovered the network cards as:

Adapter 1 = e0d

Adapter 2 = ea0

Adapter 3 = e0b

Adapter 4 = e0c

After setup the host-only networks properly (I have two: one for cluster interconnect and one for data) it works fine.

All the best,

Nascimento

NetApp - Enjoy it!

Re: Simulate ONTAP 8.1.1 withVirtualBox

Hi,

I've been trying (unsuccessfully) to get the 8.2 cmode vsim running under virtualbox under WIndows 7 (64 bit) on both AMD and Intel.

I've followed the excellent instructions from this thread, and tried both versions (esx & vmware workstation). I'm confident the setup is as it should be:

The sim boots and runs, but never seems to initialise properly following option 4 on the boot menu, returning an error saying the rootvol is not up:

If run within VMWare player, eveything appears to run as it should and I am taken to the cluster setup.

Please ignore the error about VMWare tools - this is the only occasion when I haven't disabled them, and it makes no difference to the outcome.

Any clues as to what I might have done wrong gratefully accepted. If there's a way forward from this point, I'm happy to try.

I have managed to get the 8.1 vsim running to the point of cluster setup in virtualbox. I then mounted up the cfcard vmdx, unpacked 821RC1_q_software_image.tgz into .../image2, and booted into it at which point I got plenty of messages related to an upgrade, all of which seemed to indicate success, apart from when it was all finished. I eventually rebooted, chose option 4 (wipe) from the boot menu, and (eventually) ended up with the same error message re the rootvol. This seems to be related to not being able to untar the mroot into an appropirate destination...

Thanks

Re: Simulate ONTAP 8.1.1 withVirtualBox

The only item I note off the bat is the network adapter types.  My experience is that the Intel "Desktop" adaptors don't work, and that you need to use the specific "Server" type adapter listed above in this post (be sure to check which Server type, as VBox gives you two different types).

However, with all 8.x versions previous to 8.2, the only issue the network adapter caused was to not have networking available.  Why that would affect the root volume I don't know, but on the surface that's all I have.  Working on my own 8.2 c-mode sim (have 7-mode up already) - will post anything relevant to this as might be found.

Bob

Re: Simulate ONTAP 8.1.1 withVirtualBox

Thanks Bob - although I haven't completed the cluster setup yet, I'd say you were spot on. I'd failed to pay sufficient notice to the network type which was desktop rather than server variant, having logged in to the systemshell it became obvious there were no adapters other than localhost, and under the hood of just logging in as admin there were various rpc failures which should have pointed me in this direction. As should the "allow system to boot without network adapters on AMD64" messages.

The desktop style adapters work with the 8.1.1 vsim image, but as far as I can tell no later ones.

Thanks for your help - much apreciated

Cheers

Julian

Re: Simulate ONTAP 8.1.1 withVirtualBox

This instructions worked as stated. Nice job !


BOBSHOUSEOFCARDS wrote:

There have been a small number of posts both here and in the support community about the change between the 7.3 family of OnTap simulators and those for 8.1.1.  The delivery model changed from being one where you install the simulator on a Linux system (easily setup on any virtualization platform you have) to the model in 8.1.1 Simulator where you download a full virtual machine image designed for use in a VMWare environment only.

 

Many people will have access to one of the paid options (VMWare Workstation/Fusions/ESX) or can use the free VMWare Player on Windows.  But, for those that need alternatives such as on a Linux or Solaris host platform or something free on a Mac, here are instructions to setup 8.1.1 Simulator on VirtualBox.

 

Disclaimer:  to date I have only tested this on a single Windows platform.  Specifically, I tested this on a 32 bit Windows 7 host (but on 64 bit capable hardware).  Basic setup and general operations seem normally functional, though I have not delved into all the possibilities that OnTap offers.  The 7-mode simulator is the one on which I did most checkouts since this is what I need to make available to other team members where I work.  I have done minimal setup only on cluster mode.  None of this is technically supported by NetApp, and your mileage may vary.

 

Test environment:  Dell laptop, 3GB RAM running Windows 7 SP1 32 bit; VirtualBox 4.2.4r81684; Simulate OnTap 8.1.1.  As per the VirtualBox documentation,  you will need a 64 bit processor with virtualization enhancements enabled even if the host OS is 32 bit.

 

Setup (assumes basic familiarity with VirtualBox)

 

1.  Download and install VirtualBox.  I just used defaults for setup.

 

2.  Download the 8.1.1 simulator.  Extract the files somewhere that you want them to be.

 

3.  Create a new Virtual Machine with OS type BSD, version FreeBSD (64 bit).  Memory required is 1600MB.  Don't select a virtual hard drive now, we need to select a bunch later.  Save the new machine.

 

4.  Open the Settings for the new VM.  On the System page, Processor tab, set CPU to 2

 

5.  On the Storage path, delete the CDROM from the IDE controller.  Then, add 4 virtual hard disks to the controller.  For each disk, you will choose an existing disk.  The disks you will add, in order, are "DataONTAP.vmdk", "DataONTAP-var.vmdk", "DataONTAP-nvram.vmdk", and "DataONTAP-sim.vmdk".  Finally, add a Floppy controller with a single, empty floppy drive.  When complete, the storage setup for your new virtual machine should look like:

 

6.  On the audio page, uncheck "Enable Audio".

 

7.  On the network page, you can add up to 4 network adapters in any style that you choose - host only, bridged, internal, NAT.  This provides a bit more choice than available through VMWare Player.  Having some NICs of each type certainly can setup some interesting possibilities for multiple simulators.  For each NIC you add, expand the "Advanced" section for the NIC and select "Intel PRO/1000 MT Server (82545EM)" as the adapter type.  The Simulator virtual machine only has drivers for this emulated NIC type.  A sample NIC setup would look like:

 

8.  The default setup of the VMWare virtual machine attaches a local Windows pipe as a conduit to each of two serial ports - one for the "console" and one for debugging.  You can enable serial ports and redirect, but it is not required.

 

9.  On the USB page, uncheck "Enable USB Controller".

 

10.  On the Shared Folders page, no shared folders need be created.

 

11.  Save the virtual machine.

 

12.  Be sure you have 1600MB real free memory to start the guest or it will fail during startup at some point.

 

13.  Start the virtual machine.

 

14.  During the 10 second countdown, click in the VM and press any key that is NOT Enter to stop the boot.

 

15.  Update the environment to not start the VMWare tools with command "setenv bootarg.vm.run_vmtools false"

 

16.  If you are installing a 2nd simulator this is a great time to update the serial number as per the documentation as well.

 

17.  Enter command "boot" to continue with the startup of Data OnTAP.

 

18.  When the "Press Cntrl-C for menu" appears, press Cntrl-C and wait for the boot menu.  This first boot can take a little bit to happen depending on your hosting platform.

 

19.  On the boot menu, select option 4 and confirm clearing all disks and deleting all data.

 

20.  The Simulator will restart - let it proceed normally.  After restoring a fresh Data OnTAP from the simulated media you will eventually get the prompts for standard setup of a new Filer.

 

Enjoy!


 

Re: Simulate ONTAP 8.1.1 withVirtualBox

Just used these instructions to set up an ONTAP 8.2 simulator on VirtualBox 9 and it worked perfectly.  Thanks for the great proecedural notes!

Forums