Software Development Kit (SDK) and API Discussions

Connect to vfiler with ONTAPI via HTTP/HTTPS, err=10061

cat_towerbe

Hi all,

WARNING:  I'm not a programmer. 

I'm using zexplorer to try and troubleshoot a problem with a program I'd like to use, but I'm seeing something odd when trying to connect to vfilers.

I have an active/active pair running ONTAP 8.0.2P3.

I have several vfilers running on each controller.

On controller 1, I can use an HTTP connection to any and all of the vfilers and get an appropriate response.

On controller 2, If I use an HTTP connection, I can connect with vfiler0 (the base unit), but not if I try to connect to any of the vfilers on that controller.  I get the following error message.

<results reason="Can't connect to host (err=10061)." status="failed" errno="10061"/>

This is really odd because the physical filers are a cluster pair, built at the same time, running the same version of the OS, configured identically as far as I can tell, and the vfilers were built at the same time.

Any recommendations for figuring this one out?

Thanks in advance,

Brian

1 ACCEPTED SOLUTION

rle
NetApp Alumni

Hi Brian -

Compare the HTTP options between the working vfilers and the non-working vfilers.  Here is an example below.

toaster> vfiler run vfiler1 options http

===== vfiler1

httpd.access                 legacy

httpd.admin.access           legacy

httpd.admin.enable           on

httpd.admin.hostsequiv.enable off

httpd.admin.max_connections  512

httpd.admin.top-page.authentication on

httpd.autoindex.enable       off

httpd.bypass_traverse_checking off

httpd.enable                 off

httpd.ipv6.enable            off

httpd.log.format             common

httpd.method.trace.enable    off

httpd.rootdir                XXX

I assume you have verified that the IP address are valid for the non-work vfilers by ping or rsh.

Regards,

   - Rick -

View solution in original post

3 REPLIES 3

rle
NetApp Alumni

Hi Brian -

Compare the HTTP options between the working vfilers and the non-working vfilers.  Here is an example below.

toaster> vfiler run vfiler1 options http

===== vfiler1

httpd.access                 legacy

httpd.admin.access           legacy

httpd.admin.enable           on

httpd.admin.hostsequiv.enable off

httpd.admin.max_connections  512

httpd.admin.top-page.authentication on

httpd.autoindex.enable       off

httpd.bypass_traverse_checking off

httpd.enable                 off

httpd.ipv6.enable            off

httpd.log.format             common

httpd.method.trace.enable    off

httpd.rootdir                XXX

I assume you have verified that the IP address are valid for the non-work vfilers by ping or rsh.

Regards,

   - Rick -

View solution in original post

michelvankessel

great!!! you saved my day of getting really long :-). (SnapProtect with vFilers)  I didn't know that it is not possible to change the httpd.admin.enable option from within the vfiler!   man I feel stupid 🙂  regards Michel

cat_towerbe

Where's my soft rubber bat?  I need to beat myself for not thinking of that!

Thanks Rick!!!!

Note:  This is why I LOVE communities.netapp.com.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public