Software Development Kit (SDK) and API Discussions

NaAPIFailedException: Insufficient privileges: user 'b1\mylogin' does not have read access


I am getting the below exception :

netapp.manage.NaAPIFailedException: Insufficient privileges: user 'b1\mylogin' does not have read access to this resource (errno=13003) when executing the security-login-get-iter API.

We have the mylogin with a_readonly role and a_readonly role has DEFAULT as well as security directory readonly access.

e.g as below:


UserName Application Method Role Name Locked
---------------- ----------- -------------- ---------------- ------
mylogin ontapi domain a_readonly -


Role Command/ Access
Vserver Name Directory Query Level
---------- ------------- --------- ----------------------------------- --------
cluster01 a_readonly DEFAULT readonly

cluster01 a_readonly security readonly


Is there any other access that needs to be granted, especially if I have Application Method as domain ?



Have you tried specifying the domain when you create the user account?


eg b1\mylogin

I have not tried giving the domain when you create the user account but there are many other api which are working fine. Just the security api is having issues.

I have not but the user works for other commands. Only the security one is failing.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.