VMware Solutions Discussions

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

 are you using VSC 6.2 with vSphere 6.0 or 5.5?  Did you just recently upgrade?

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

yes recently upgraded.

Was on 5.1 and build out a brand new vCSA with external PSC on 6.0 update 2.

Migrated the hosts over and upgraded to latest release as well.

 

After completion the VSC was upgraded to 6.2 (from 4.2.2) and registered to the new vSphere 6 vCSA.  (migrated the repository as well since used for backups/restores and moved to new server)

hosts started disappearing and web client became unusable..

 

tried the following solutions with no results:

disconnect and remove hosts.

restarted the vCSA

 

 

only after removing the plugin through MOB extention manager and restarting the VCSA was I able to see the hosts again and have a consistent environment.

 

 

 

 

 

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

Ah, it sounds like the issue everyone is having.  Hopefully NetApp comes back with a solution soon.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

I have the same issue with VSC 6.2 on vSphere VCSA 6.0.2 and 6.0.1. I called to open a ticket and the tcehnician acted like he had never heard if this issue before and asked that I pull logs from the  VSC and vCenter web client. I will simply not be using the VSC plugin until they work this bug out. It is quite sad that this isnt a known issue and addressed as such based on the amount of the community members experiencing the problem.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

I reverted to 6.1 and now having better stability with the hosts not disappearing as frequently and makes the web client usuable.  At least this a workaround on my side until they provide a fix.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

I have downgraded to VSC 6.0 per Netapps tech support.   This seems to be working for me.  I would open a case with Netapp and they have some prep/cleanup steps you can follow before you install the downgraded version.   Note: I am running Virtual Center appliance 6.0 Update 2.   Netapp has not fully vetted out VSC 6.0 on VSCA 6.0 U2 but was the suggested work around and so far so good.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

 I was about to try 6.2 but from your feedback it seems going to 6.0 is the safer bet.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

give the VCenter more RAM and more CPU Power,it helps a little bit

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

A new patch for VSC has been released, 6.2P1.  It can be downloaded here:

http://mysupport.netapp.com/NOW/download/software/vsc_win/6.2P1/

 

The bug/BURT in question, ESX hosts being hidden in inventory, is 980727.

 

VSC 6.2 merges the seperateness of VVOLs/VP in 6.0 and no VVOLs but integration with SnapCenter 1.0 of VSC 6.1.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

I applied this the day it came out and it seems to have done the trick for us.  

 

I heard from support it was a bad API on vmware's part and this patch basically removes the use of that API.  

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

We have the P1 update installed now and it works without issues.

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

Installing VSC patch 6.2P1 also fixed my issue with hosts disappearing from vCenter.  However, it seems to have introduced a new one.  My hosts now randomly disconnect from vCenter.  vCenter logs would indicated that there was an error with the host name in subject for the host certificate.  I have verified the host cert and thumbprint as being correct.  Since unregistering VSC from vCenter and shutting it down the random host disconnects have stopped.  Has anyone else been experiencing this issue with VSC?

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

Did you continue to see the issue with ESXi host disconnecting after installing 6.2P1? Do you see them disconnecting in the recent tasks area?

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

Hello,

 

I have implemented VSC 6.2P1 and have not experienced any disappearing hosts anymore. I am now in the process of upgrading/installing the other components (VASA/SRA 3.0) to get my VMware SRM environment active again.

 

So far so good!

Highlighted

Re: ESX host disappears from vCenter webclient inventory when VSC 6.1 is installed.

I have not either. We are using vSphere 6.0 Update 2 and a vCenter 6.0 Appliance.

Check out the KB!
Knowledge Base
All Community Forums