The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

MBRALIGN caused "Error Loading Operating System" on template

alliantenergynjk

We were told by NetApp to run the MBRALIGN on our servers.  Seeing this as a LOT of work, I decided to do it first on our Windows 2003 template so that at least any NEW VMs would have correct alignment.  I started in our LAB first before attempting production.

So I scanned the VMDK files in our lab and indeed it flagged the template VMDK file as not being aligned - cool...so far so good.  The template was off, obviously cause its a template, and had no snapshot.  I ran the alignment process on it and after about 45 minutes it completed, 100%, no errors.

I converted the template to a VM this morning to power it up and make sure the OS was still OK before I deleted the backup files the alignment tool created.  I get this error:

Error Loading Operating System.

I also could not edit the VM in Virtual Center.  It gave me this error:

The server fault 'SystemError' had no message.

Error Stack

Call "PropertyCollector.RetrieveContents" for object "propertyCollector" on vCenter Server "ourservername" failed.

Cool - love it....

Does anyone know what might cause this or what might have gone wrong?  Was I not supposed to run this on a template?  Should I have converted it to a VM first before running the alignment tool on it?

Thanks

NK

1 ACCEPTED SOLUTION

forgette

Hello.  I'm sorry to report you've stepped on a bug in 5.2.  The following Knowledge Base article should help: kb59502

The work around at this point is to download the ESX Host Utilities Kit 5.1 and extract the mbralign utility from it.

View solution in original post

4 REPLIES 4

f_duranti

I got the same problem on a Win2003 machine with the latest version of mbralign (the one in VSC 2.0 and esx_host_utils 5.2). I used it on ESX 4.0update1 machine and got exactly the same errors.

I was thinking about a "compatibility" problem and was waiting to upgrade to ESX 4.1 (but I cannot because there's no SRA for SRM 4.1 available).


Using the mbralign utilities from esx_host_utilities 5.1 (the one with separate mbrscan/mbralign programs) I had no problem to align Windows 2000/2003 machines.

I've never tried with a template, I just converted it to VM then run the mbralign then converted it back to Template.

I thnk the problem can be the new MBRALIGN, what version of it are you running and on what vsphere version?

Hi,

Thanks for the response.

I am running the Host Utils version 5.2 (where mbrscan has been merged into mbralign) and ESX 4.0 in our lab.  I am running vCenter 4.1, but our lab is ESX 4.0 still.  None of our lab environment is running on NetApp (yet) - but I was told the alignment problem is a global issue with both physcial and virtual servers running on ANY type of storage.  My understanding was the MBRALIGN could be run on any storage backend - not just NETAPP.  But we are planning on migrating to NETAPP and so that is what started this whole thing.

Thanks

NK

forgette

Hello.  I'm sorry to report you've stepped on a bug in 5.2.  The following Knowledge Base article should help: kb59502

The work around at this point is to download the ESX Host Utilities Kit 5.1 and extract the mbralign utility from it.

View solution in original post

alliantenergynjk

Thank you.  I will try out the older version.

NK

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public