VMware Solutions Discussions

VSC 4.2 Beta multistore license required?

jasonpnnl

Just installed the VSC 4.2 Beta in my test environment. Tried adding a controller to Monitoring and Host Configuration but it won't connect. Error message in VSC is "The call failed on the server; see server".

Checked vsc.log on the server and see the following error:

2013-03-11 13:00:44,210 [qtp692200324-27] ERROR (ControllerUtil) - invokeZAPI: failed Controller[XXXX] API failed. Api vfiler-list-info requires license for multistore (errno=13008) (called from com.netapp.exoforce.server.zapi.ControllerUtil7Mode.checkifDirectVfiler(...) on line 1394)

So it seems to be checking for a multistore license. Is this a new requirement or what is going on here?

Thanks,

Jason

9 REPLIES 9

Re: VSC 4.2 Beta multistore license required?

dbkelly

Jason,

Can you give me some more information about your environment?    For starters, what ONTAP version are are running on the controller you are trying to add.

-David

Re: VSC 4.2 Beta multistore license required?

jasonpnnl

Hi David,

I am running 8.0.3P3 on the filer. The vsc.log says it is ONTAPI version 1.13.

Jason

Re: VSC 4.2 Beta multistore license required?

jasonpnnl

David - any thoughts? Is this a bug and just need to wait for next version?

Re: VSC 4.2 Beta multistore license required?

MIKE_ELLIS

I am running into the same issue with 4.2x3 beta

Referenced thread here: https://communities.netapp.com/thread/27886

Re: VSC 4.2 Beta multistore license required?

schrie

This appears to have been also found by QA during VSC 4.2 testing, and appears to be resolved in a build which shows fixed at the beginning of March - could you try the latest X build for the BETA and email xdl-vsc-feedback@netapp.com if you continue having this problem?

View solution in original post

Re: VSC 4.2 Beta multistore license required?

jasonpnnl

The problem is resolved in 4.2X7.

Thanks!

Re: VSC 4.2 Beta multistore license required?

roberto_navarro

Are you sure it's fixed?

Just upgraded from 4.1 to 4.2x7 and issue is still there. i found this looking at wrapper.log:

INFO   | jvm 1    | 2013/05/16 18:31:17 | 2013-05-16 18:31:17,026 [VMExaminer-VIRTUAL_MACHINE-1368721876901] ERROR com.netapp.caster.server.scanmanager.VMExaminerService - Failed to examine VM

INFO   | jvm 1    | 2013/05/16 18:31:17 | com.netapp.kamino.data.ZapiException: Could not initialize class com.netapp.alignment.virtualDisk.VirtualDiskInfo

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at com.netapp.kamino.server.duplicator.VmdkFile.<init>(VmdkFile.java:295)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at com.netapp.caster.server.scanmanager.VMExaminerService.configureScanContextForSnapshot(VMExaminerService.java:260)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at com.netapp.caster.server.scanmanager.VMExaminerService.examine(VMExaminerService.java:166)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at com.netapp.caster.server.scanmanager.VMExaminer.run(VMExaminer.java:27)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

INFO   | jvm 1    | 2013/05/16 18:31:17 |           at java.lang.Thread.run(Unknown Source)

INFO   | jvm 1    | 2013/05/16 18:31:17 | 2013-05-16 18:31:17,026 [VMExaminer-lincl876.neuroinvest.net-1368721876901] INFO  com.netapp.caster.server.scanmanager.VMExaminerService - Cleaning up any remaining snapshots

INFO   | jvm 1    | 2013/05/16 18:31:17 | 2013-05-16 18:31:17,041 [VMExaminer-lincl876.neuroinvest.net-1368721876901] INFO  com.netapp.caster.server.scanmanager.VMExaminerService - Finished scanning virtual machine: VIRTUAL_MACHINE (5230aed9-8935-f009-6bd1-d4b5e31d92e5)

Re: VSC 4.2 Beta multistore license required?

brianjm

The above error suggests a problem loading the VDDK native libraries used to scan for misalignment.

It won't have any effect on adding controllers to VSC.

For this error - are you running VSC on a Windows 2003 machine?  If so, you'll need to get .Net 3.5 installed.

Re: VSC 4.2 Beta multistore license required?

roberto_navarro

VSC is installed in x64 Windows 2008 R2 SP1 (standard edition) server.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public