VMware Solutions Discussions

VSC 5 - Account locked when try to access or edit Backup Jobs

haven2008

Hi all,

running vSphere 5.5 and found an Issue.

when i try to access, edit a Backup Job or click the Backup Section in vSphere Web Client, the Account comes locked immediately.

this Account is a Domain Account with full Privilege to Datacenter and all Objects in vSphere Client

i was able to create Backup Jobs for any existing VM and the Jobs running fine in the Background.

Currently, i could not found what exact the Problem is.

Mysterious . . .

cheers,

Mario

40 REPLIES 40

hoazemhoazem

I had a case open with netapp and got the solution yesterday:

We can work around this issue by adding an entry in the smvi.override file which will ensure that the Windows Authentication Handler is not called to authenticate the incoming soap request.

The steps are as follows :

1) Open the smvi.override file present at the following location on the m/c where VSC is installed - C:\Program Files\NetApp\Virtual Storage Console\smvi\server\etc

2) Add the following line to the file :

  1. authentication.chain.1=com.netapp.smvi.security.authentication.handler.VSphereAuthenticationHandler

3) Save the changes to the file.

4) Restart the NetApp SnapManager for Virtual Infrastructure service.

this fix worked for me

c_delporte

same issue for me last week

kingj

Good morning.  Please creat case (if you haven't already) with NetApp Support and explain that you have likely encountered Bug 821600.  There is now a fix for this.

GenosMan

Fixed -

One of two things fixed it, most likely #2

1. Deleted a return line at the end of the file

2. noticed the file was named .override.override, so I removed the incorrect redundancy

Looking forward to the update that resolves this!

schrie

Hey Philip -

Could you open a case with support so we can give you a hand and make sure your issue is properly tracked?  If the above solution isn't working after adding the line to the smvi.override, saving, then restarting the service, you are likely hitting another problem.

Could you email me the case number once you open it so I can escalate it immediately?

*jenn

GenosMan

It is now August 12th. Is this bug going to be fixed? I see there is a 5.0.1 beta, is the bug fixed here? How do I access this? Thank you.

STEPHAN_H

Hallo,
same question.
Because the Workarround is slowing down the WebClient.

Every time any of the NetApp Plug-in have to load in the window, it tooks very long.

To create one or more jobs, it feels like hours.

schrie

This problem has been resolved in NetApp BURT 821600 - a workaround has been provided as follows:

  • Open the smvi.override file present at the following location on the m/c where VSC is installed - C:\Program Files\NetApp\Virtual Storage Console\smvi\server\etc
  • Add the following line to the file :
    • authentication.chain.1=com.netapp.smvi.security.authentication.handler.VSphereAuthenticationHandler
  • Save the changes to the file.
  • Restart the NetApp SnapManager for Virtual Infrastructure service.

GenosMan

Good afternoon,

 

Any update when this bug will be resolved?

Golazo

This bug is fix in VSC 5.0P1.

nelias1988

just installed 5.0P1 same issue again... any one else got the same problems even with 5.0P1 installed?

STEPHAN_H

Thx!

the workaround is working in our environment.

Stephan

schrie

Great to hear! If you "watch" the bug it will tell you once it's been resolved permanently

Have a great week,

*jenn

Sent from my Samsung Galaxy Note® II

CANDERSSON1982

Hi!

I did the workaround and no lockouts so far

Thank you for this solution!

//Christian

schrie

No problem! Go ahead and "watch" the bug for the permanent fix.

Have a great week!

*jenn

Sent from my Samsung Galaxy Note® II

lucienorrin

I MIGHT have worked for me.

I used notepad to open the smvi.override file, all the text was on one line. I dropped down one line and entered the text.

After restarting the services and logging in with my domain account everything seems good to go. So far my domain account has not been locked out again.

I went back in to look at the smvi.override file and the text had been moved up with the rest of the text on the first line.

I would imagine something isn't working right as a result.

The end of the string looks like this:

"...vmware.quiesce.retry.interval=5authentication.chain.1=com.netapp.smvi.security.authentication.handler.VSphereAuthenticationHandler"

                                                 ^

Is the correct format for the fix, or will this have unintended consequences?

Thanks!

schrie

You can edit the file in wordpad instead of notepad to avoid the one line issue. It looks a lot cleaner!

Sent from my Samsung Galaxy Note® II

GenosMan

This workaround doesn't work. I restarted both of the services(Netapp and the VSC service) with no luck, still locking out every time. When is the expected date when the actual code will be fixed?

Is this how the smvi.override should look?

credential.persistence.file.path=etc\\cred

http.ssl.keystore.file=etc\\smvi.keystore

#

# Maximum number of concurrent VMware snapshots to perform server side.

# This number is checked on a per datastore basis.

#

#vmware.max.concurrent.snapshots=6

#

# Maximum number of retry for vmware snapshots for "...time limit for holding off I/O..."

# errors

#

#vmware.quiesce.retry.count=0

# Delay between retries for vmware snapshot error "...time limit for holding off I/O..."

# in seconds

#

#vmware.quiesce.retry.interval=5

authentication.chain.1=com.netapp.smvi.security.authentication.handler.VSphereAuthenticationHandler

schrie

Yes that looks right - are there any line breaks or spaces in the extra line? Did you save the file before restarting?

Could you open a new support case on Monday when you get in (and send me the case number) so I can do a deep dive on this with you?

Sent from my Samsung Galaxy Note® II

basisinfra

Also the same problem here! Created a case by NetApp!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public