VMware Solutions Discussions

VSC Backup & Recovery "Could not log onto the storage system" error

mital_shah

Today I faced an issue where a client running NetApp Virtual Storage Console experienced backup failures with following error:

VSC Backup Error:

2014-07-23 11:00:01,723 PROGRESS - Starting backup request
2014-07-23 11:00:03,517 INFO - Generating backupName for the scheduleJob xxxxxx-5d77-43c6-b6e8-c9e9a95fcdf8 is backup_Datastore-XXX-Hourly_20140723110003
2014-07-23 11:00:03,579 INFO - No storage system configured with interface "X.X.X.X" (X.X.X.X)
2014-07-23 11:00:03,579 WARN - FLOW-11020: Ignoring NaSnapshotsRenameAction failure: No storage system configured with interface "192.168.0.233" (192.168.0.233)
2014-07-23 11:00:04,765 INFO - No storage systems found with FCP node name "xx:xx:xx:xx:xx:xx:xx:xx"
2014-07-23 11:00:04,765 INFO - Unable to manage datastore datastore-122: No storage system defined for target "xx:xx:xx:xx:xx:xx:xx:xx" used by datastore NetApp_XXX(515ab2b8-bbed6a24-dc9c-2c768a554024)
2014-07-23 11:00:04,765 WARN - Could not find the following backup ids as either a datastore or virtual machine: [xxxxxx-bbed6a24-dc9c-2c768a554024]
2014-07-23 11:00:04,765 ERROR - Did not find any of the following datastores or virtual machines to backup: [xxxxx-bbed6a24-dc9c-2c768a554024]
2014-07-23 11:00:04,780 ERROR - FLOW-11019: Failure in VmGetVirtualMachinesToBackup: Did not find any of the following datastores or virtual machines to backup: [xxxxxx-bbed6a24-dc9c-2c768a554024]
2014-07-23 11:00:04,780 ERROR - FLOW-11010: Operation transitioning to abort due to prior failure.

Looking into VSC --> Backup & Recovery --> Setup, the storage systems did not appear. When trying to add them again, it threw the error:  "Could not log onto the storage system <storagename> with the provided credentials", through the Credentials were correct & could successfully log into via SSH with same credentials. I also came across these older threads [https://communities.netapp.com/thread/16969] pointing to SSL, I ran secureadmin setup ssl again on both controllers but it didn't resolve my issue. There is also a bug: 526771 [SSL handshake fails if only one of SSLv3 or TLSv1 is enabled -
http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=526771 ], but those didn't help me resolve the issue.

The VSC --> Monitoring & Configuration --> Overview was fine - it displayed the NetApp controllers, and I could Update/Refresh the data.

Rather than attempting to repair VSC, since I was running VSC 4.1, I decided to upgrade VSC. Looking at the VSC Intercompatibility Matrix, I realised that the VSC4.1 was not compatible with ONTAP 8.2.1, which I had upgraded the controllers to about 3-4weeks ago. [Despite the upgrade, it did work fine for 3-4weeks, then disrupted somehow]

Thankfully VSC upgrade to 4.2.1 immediately resolved the issue and the Backups ran fine immediately. [In VSC4.2.1, they no longer even have the options to add controllers within Backup & Recovery --> Setup]

Thought I would post this, incase someone faces the same issue.

1 REPLY 1

SEARNHARDT

Hey!  I wanted to put in a solution that worked for me for a similar error.  I was simply trying to get VSC to recognize the NetApp filers and kept getting connectivity and permission errors.  Long story short, I had HP Network Teaming (default mode) setup on my vCenter server.  After several weeks of different troubleshooting, with no luck, we switched to teaming mode to Active / Passive and it now works perfectly.  This soultion was tested with VSC 4 and with VSC 5 as both were having the same problems.  Again, since I didn't see this solution anywhere, I just wanted to post it in the hopes of helping someone else out!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public