VMware Solutions Discussions

VSC upgrade&migration between two servers


I would like to know about the right procedure to migrate VSC configuration and data files and also licensing.

We are currently migrating our VMware ESX servers and one of the pieces we have to upgrade is vCenter.

We have installed the new vCenter (v 5.1) in a new server (with new IP) and we have also installed VSC v 4.1. In the currently working server we have vCenter 4.0.0 and VSC 2.0.1P1.

We haven't found any procedure describing specifically the migration of VSC in NetApp documentation (there is info about upgrading VSC on the same server) but we have found some useful info in this thread:


We have followed the described steps but when we tried to restart the NetApp SMVI service in the new server with VSC 4.1 and with the copied configuration and data from the initial VSC (v.2.0.1P1) we get an error that we attach separately in the following file:

C:\Program Files\NetApp\Virtual Storage Console\smvi\server\log\wrapper.log

We bought an SMVI license a long time ago and it

was two years ago that we migrated from SMVI installed in a separate server to VSC 2.0.1P1 running in the vCenter server without any licensing or other kind of problems. Looking at the log file it seems that there is a problem with the license but we currently have a 'bundle license' and we do not know how to solve it.

We are specially worried in keeping the VMs backup that we are retaining (30 days, 30 snapshots) available in the new installation of VSC 4.1 linked to the new vCenter (5.1) running under Windows Server 2008 R2 SP1 64bit to be able to restore any VM if we need it.

As we have not found any VSC migration procedure we are stuck in the middle of the general upgrade for the VM infrastructure.

We would thank any kind of help in this issue.

Best regards.

                   jesus .+


OS Version: NetApp DATA ONTAP 8.1 7-Mode



Finally I solved the problem after upgrading the source VSC to 4.1.

But in the second iteration of the procedure I realized that the first time I had copied the whole directory

C:\Program Files\NetApp\Virtual Storage Console\smvi\server\etc\*

instead of uniquely the file

C:\Program Files\NetApp\Virtual Storage Console\smvi\server\etc\cred

When I repeated the operation copying only the 'cred' file (I also copied the folder C:\Program Files\NetApp\Virtual Storage Console\smvi\server\repository\) it worked perfectly. The NetApp SMVI service could start normally and when I accessed the VSC I could see the original configuration (jobs, credentials, backups, ...).

Sorry, I was confused because initially I followed this article in the knowledge base that talks about migrating from SMVI to VSC:


Thanks again.

    jesus .+